Bug 42915 - Installation with iso failed with "Installing univention-welcome-screen failed"
Installation with iso failed with "Installing univention-welcome-screen failed"
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-4-errata
Assigned To: Erik Damrose
Stefan Gohmann
:
Depends on:
Blocks: 43589
  Show dependency treegraph
 
Reported: 2016-11-09 23:54 CET by Michel Smidt
Modified: 2017-02-22 12:32 CET (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.411
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?: Yes
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Installation failed (55.67 KB, image/png)
2016-11-09 23:54 CET, Michel Smidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Smidt univentionstaff 2016-11-09 23:54:03 CET
Created attachment 8211 [details]
Installation failed

Downloaded the iso on 8.11.2016
Installation failed reproducible with message "Installing univention-welcome-screen failed" (screenshot attached). Due to an ongoing workshop I got no logs.
During base installation no further components were selected and the checkbox "Automatically update the system" wasn't checked. Furthermore the systems had no access to the internet during installation.

Fortunately the installation worked with an older iso.
Comment 1 Erik Damrose univentionstaff 2016-11-10 09:42:41 CET
(In reply to Michel Smidt from comment #0)
> Downloaded the iso on 8.11.2016

Which ISO file did you download from which URI?
Comment 2 Michel Smidt univentionstaff 2016-11-10 20:32:14 CET
(In reply to Erik Damrose from comment #1)
> (In reply to Michel Smidt from comment #0)
> > Downloaded the iso on 8.11.2016
> 
> Which ISO file did you download from which URI?

The UCS-Installation-amd64.iso
from:
https://www.univention.de/download/ucs-download/iso-installationsimage/download-iso-image/

I can provide you with the iso but didn't want to upload it here ;-)
Comment 3 Erik Damrose univentionstaff 2016-11-11 10:03:12 CET
Can you add the md5sum of the iso file? On November 8th we released UCS 4.1-4, so it is currently unclear if you got the 4.1-3 or 4.1-4 ISO
Comment 4 Michel Smidt univentionstaff 2016-11-11 10:10:09 CET
(In reply to Erik Damrose from comment #3)
> Can you add the md5sum of the iso file? On November 8th we released UCS
> 4.1-4, so it is currently unclear if you got the 4.1-3 or 4.1-4 ISO

b72705313ac55325f21e81645d45b662

Maybe related: The systems were behind a proxy.
Comment 5 Erik Damrose univentionstaff 2016-11-11 11:14:58 CET
The md5sum shows that this was the UCS 4.1-3 ISO.

I can reproduce the issue, although in my test no error message was shown and the debian installer simply finished.

The issue is, again, with /etc/apt/apt.conf.d/99updatecheck.conf , see bug 42808#c3

With no available internet connection there is a traceback in 15_ucs-online-version.list, and that prevents any APT operation, although the package is installable from the ISO.
Comment 6 Stefan Gohmann univentionstaff 2016-11-28 08:10:58 CET
I think we should install univention-welcome-screen already during the normal package installation.
Comment 7 Erik Damrose univentionstaff 2017-02-10 10:59:02 CET
Occured again during a remote session with a customer
Comment 8 Erik Damrose univentionstaff 2017-02-15 16:22:41 CET
I moved to installation from appliance-hooks.d to the 90_postjoin section. Call order puts it before the activation of the repositories, which is in 20_update.

u-welcome-screen is among the packages that are already downloaded by usr/share/univention-system-setup/download-packages

r76700 univention-system-setup 9.0.7-3.1014.201702151539
r76701 merge to UCS 4.2
r76703 yaml
Comment 9 Erik Damrose univentionstaff 2017-02-16 11:31:48 CET
I created a new test DVD with the fixed version: ucs_4.1-4-20170215-165513-dvd-amd64.iso
Works fine in my tests, when i deactivate network access while the installer is running.
Comment 10 Stefan Gohmann univentionstaff 2017-02-21 15:00:44 CET
Tests: OK, it works now as expected

Code review: OK

UCS 4.2 merge: OK

YAML: OK
Comment 11 Janek Walkenhorst univentionstaff 2017-02-22 12:32:59 CET
<http://errata.software-univention.de/ucs/4.1/401.html>