Bug 43038 - Show App (migration) update for Docker Apps
Show App (migration) update for Docker Apps
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-4-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks: 42243
  Show dependency treegraph
 
Reported: 2016-11-22 16:22 CET by Felix Botner
Modified: 2016-12-14 12:36 CET (History)
0 users

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-11-22 16:22:42 CET
* UCS with non-Docker App 
* Docker version available
* currently, no update is displayed in UMC

We need to inform the user about the update and docker migration, idea:

=> new optional AppCenter ini var DockerMigrationLink=HTTP_LINK

=> IF DockerMigrationLink is set

   appcenter should inform the user about the update (non-docker -> docker),
   but instead of updating the app, a message like

   "The next App Version uses container technology. A manual migration has
    to be performed. Further information can be found on HTTP_LINK"

    is display

better ideas?
Comment 1 Dirk Wiesenthal univentionstaff 2016-12-12 18:53:48 CET
univention-appcenter 5.0.23-20.248.201612121851
Comment 2 Felix Botner univentionstaff 2016-12-13 15:07:16 CET
-> ucr get appcenter/prudence/docker/tine20 
yes
root@master:~# univention-upgrade 

Starting univention-upgrade. Current UCS version is 4.1-4 errata353

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               found

The following apps can be upgraded:

Tine 2.0: Version 2015.11.14 can be upgraded to 2015.11.15-ucs1

Starting app upgrade                                   
Do you want to upgrade Tine 2.0 [Y|n]? y

An error occurred - see "/var/log/univention/updater.log" for details

 14718 actions.upgrade-search.progress  16-12-13 15:06:35 [   DEBUG]: 100
 14718 actions.upgrade                  16-12-13 15:06:35 [   ERROR]: 'migration_guide'
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/__init__.py", line 191, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/upgrade.py", line 70, in main
    return self.do_it(args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install_base.py", line 99, in do_it
    can_continue = self._handle_errors(app, args, errors, True)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install_base.py", line 153, in _handle_errors
    message = requirement.func.__doc__ % details
KeyError: 'migration_guide'
Comment 3 Dirk Wiesenthal univentionstaff 2016-12-14 00:56:14 CET
Fixed in
  univention-appcenter 5.0.23-21.249.201612140053
Comment 4 Felix Botner univentionstaff 2016-12-14 09:40:48 CET
(In reply to Dirk Wiesenthal from comment #3)
> Fixed in
>   univention-appcenter 5.0.23-21.249.201612140053

hmm, now i get 

2016-12-14 09:38:39,182 DEBUG:univention.appcenter.actions.upgrade-search.progress:100
'docker_migration_link'
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/__init__.py", line 191, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/upgrade.py", line 70, in main
    return self.do_it(args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install_base.py", line 99, in do_it
    can_continue = self._handle_errors(app, args, errors, True)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install_base.py", line 153, in _handle_errors
    message = requirement.func.__doc__ % details
KeyError: 'docker_migration_link'

UMC works though
Comment 5 Dirk Wiesenthal univentionstaff 2016-12-14 10:00:47 CET
Hmpf. Fixed in
  univention-appcenter 5.0.23-22.250.201612140959
Comment 6 Felix Botner univentionstaff 2016-12-14 11:45:07 CET
OK
Comment 7 Janek Walkenhorst univentionstaff 2016-12-14 12:36:50 CET
<http://errata.software-univention.de/ucs/4.1/357.html>