Bug 43177 - univention-app upgrade for docker app updates only default packages
univention-app upgrade for docker app updates only default packages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-4-errata
Assigned To: Felix Botner
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-14 11:24 CET by Felix Botner
Modified: 2017-01-18 13:58 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.086
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-12-14 11:24:13 CET
see univention-docker-container-mode/usr/share/univention-docker-container-mode/update_app_version

only the apps default packages is upgraded

this is different to the non-Docker app upgrade where all the errata packages are upgraded as well
Comment 1 Dirk Wiesenthal univentionstaff 2016-12-14 11:28:09 CET
In update_app_version, /usr/share/univention-updater/univention-updater-check is run. Replacing it with univention-upgrade should be enough?

Not sure whether or not it should install release updates at this point. If not, update/available should be set, just in case.
Comment 2 Felix Botner univentionstaff 2016-12-14 15:56:03 CET
added

univention-upgrade --noninteractive --updateto "$(ucr get version/version)-$(ucr get version/patchlevel)" --disable-app-updates

to univention-docker-container-mode/update_app_version

no release update at this point.

univention-docker-container-mode: r75284
merged to 4.2-0
Comment 3 Dirk Wiesenthal univentionstaff 2016-12-21 01:47:27 CET
Instead of running univention-upgrade directly, could you please use /usr/share/univention-docker-container-mode/update_packages (also runs univention-run-joinscripts!)? Seems a bit better as update_app_version will benefit from update_package fixes.

Also: 'die "Could not update the app packages"' is not completely wrong. But the script is also used for the initial package installation. That's why is was 'die "Could not install the app"'. You can leave it as is if you think the error message is okayish for "univention-app install". I don't mind, just wanted to let you know.
Comment 4 Felix Botner univentionstaff 2016-12-21 12:51:21 CET
(In reply to Dirk Wiesenthal from comment #3)
> Instead of running univention-upgrade directly, could you please use
> /usr/share/univention-docker-container-mode/update_packages (also runs
> univention-run-joinscripts!)? Seems a bit better as update_app_version will
> benefit from update_package fixes.
> 
> Also: 'die "Could not update the app packages"' is not completely wrong. But
> the script is also used for the initial package installation. That's why is
> was 'die "Could not install the app"'. You can leave it as is if you think
> the error message is okayish for "univention-app install". I don't mind,
> just wanted to let you know.

OK, remove univention-upgrade and added ...ainer-mode/update_packages "$@"
r75467
merged to 4.2-0
yaml updated
Comment 5 Dirk Wiesenthal univentionstaff 2017-01-10 01:56:04 CET
Works. If you compare the initial version to this one, update_app_version lost /usr/share/univention-updater/univention-updater-check. Can you add it to update_packages? Would make sense anyway.

I like to have set update/available to the correct value as soon as possible.
Comment 6 Felix Botner univentionstaff 2017-01-16 13:34:48 CET
readded univention-updater-check
univention-docker-container-mode: 1.0.14-7.68.201701161330
merged to 4.2-0
Comment 7 Dirk Wiesenthal univentionstaff 2017-01-17 10:00:44 CET
Changeset: OK
YAML: OK
4.2: OK
Comment 8 Janek Walkenhorst univentionstaff 2017-01-18 13:58:24 CET
<http://errata.software-univention.de/ucs/4.1/378.html>