Bug 43238 - app upgrade in univention-upgrade fails if started without proper terminal (via ssh)
app upgrade in univention-upgrade fails if started without proper terminal (v...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-21 15:02 CET by Felix Botner
Modified: 2017-10-25 14:49 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.160
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
updater.log (2.85 MB, text/x-log)
2016-12-21 15:03 CET, Felix Botner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-12-21 15:02:31 CET
UCS 4.1-4 + oxseforucs=7.8.1-7-ucs1

from another computer i started the update via ssh

-> sshpass -p univention ssh -o StrictHostKeyChecking=no root@10.200.7.150 'univention-upgrade --noninteractive'

in updater.log i get some weired error messages from the postinst scripts and the update fails (package status is broken)

...
sed: couldn't close stdout: Ungültiger Dateideskriptor
sed: couldn't close stdout: Ungültiger Dateideskriptor
sed: couldn't close stdout: Ungültiger Dateideskriptor
sed: couldn't close stdout: Ungültiger Dateideskriptor
/opt/open-xchange/appsuite/share/update-themes.sh: Zeile 49: echo: Schreibfehler: Ungültiger Dateideskriptor
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
...

-> dpkg -C
Die folgenden Pakete wurden entpackt, aber noch nicht konfiguriert.
Sie müssen mit dpkg --configure oder dem Konfigurations-Menüeintrag in
dselect konfiguriert werden, damit sie ordnungsgemäß funktionieren:
 open-xchange-meta-ui-appsuite The Open-Xchange Meta package for the OX App Sui
 open-xchange-appsuite-backend Backend extensions to serve OX App Suite fronten

Die folgenden Pakete sind nur halb konfiguriert, wahrscheinlich durch
Probleme während der ersten Konfiguration. Die Konfiguration sollte mit
dpkg --configure <Paket> oder mit dem Konfigurations-Menüeintrag in
dselect erneut versucht werden:
 open-xchange-appsuite-manifest Manifest and apps included in the OX App Suite

This also happens when upgrading an app via univention-upgrade in jenkins.
Comment 1 Felix Botner univentionstaff 2016-12-21 15:03:10 CET
Created attachment 8319 [details]
updater.log
Comment 2 Felix Botner univentionstaff 2017-06-21 10:40:30 CEST
This breaks the package status, should be fixed for 4.2 and 4.1.
Comment 3 Felix Botner univentionstaff 2017-07-05 16:07:30 CEST
siehe auch https://forge.univention.org/bugzilla/show_bug.cgi?id=44031
Comment 4 Felix Botner univentionstaff 2017-07-05 16:26:36 CEST
best solution so far

remove '-o', 'APT::Status-Fd=1' from python/appcenter/actions/install_base.py _apt_get()
Comment 5 Florian Best univentionstaff 2017-08-10 11:28:29 CEST
The code exists since UCS 4.0 docker component svn r61049 Bug #38194.
Comment 6 Dirk Wiesenthal univentionstaff 2017-10-19 12:39:26 CEST
Fixed in
  univention-appcenter 6.0.10-17A~4.2.0.201710191114

Could not reproduce, though.
Comment 7 Felix Botner univentionstaff 2017-10-20 11:09:50 CEST
i get now

  3695 actions.upgrade                  17-10-20 11:06:45 [   ERROR]: _install_packages() got multiple values for keyword argument 'update'
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/__init__.py", line 226, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/upgrade.py", line 75, in main
    return self.do_it(args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install_base.py", line 98, in do_it
    self._do_it(app, args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/docker_upgrade.py", line 96, in _do_it
    return super(Upgrade, self)._do_it(app, args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/docker_install.py", line 66, in _do_it
    ret = super(Install, self)._do_it(app, args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install.py", line 88, in _do_it
    if self._install_app(app, args):
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/docker_install.py", line 54, in _install_app
    return super(Install, self)._install_app(app, args)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install.py", line 161, in _install_app
    self._install_master_packages(app)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/install.py", line 103, in _install_master_packages
    ret = self._install_packages(app.default_packages_master)
  File "/usr/lib/pymodules/python2.7/univention/appcenter/actions/upgrade.py", line 99, in _install_packages
    super(Upgrade, self)._install_packages(packages, 0, update=update)
TypeError: _install_packages() got multiple values for keyword argument 'update'

4.2-2 with an old ox app

started update via ssh with

-> sshpass -p univention ssh -o StrictHostKeyChecking=no root@10.200.7.150 'univention-upgrade --noninteractive --ignoressh --ignoreterm'
Comment 8 Dirk Wiesenthal univentionstaff 2017-10-20 15:04:11 CEST
Fixed in
  univention-appcenter 6.0.10-19A~4.2.0.201710201120
Comment 9 Felix Botner univentionstaff 2017-10-20 15:08:59 CEST
OK - update via ssh works
OK - yaml
Comment 10 Arvid Requate univentionstaff 2017-10-25 14:49:32 CEST
<http://errata.software-univention.de/ucs/4.2/204.html>