Bug 43381 - Regression: Join hangs because of upper/lowercase mismatch
Regression: Join hangs because of upper/lowercase mismatch
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: SSL
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-4-errata
Assigned To: Felix Botner
Philipp Hahn
:
Depends on: 39068
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-20 11:40 CET by Erik Damrose
Modified: 2017-02-08 14:22 CET (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2016090521000405
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2017-01-20 11:40:32 CET
Bug #39068 r75074 introduced a hostname (line 629) call to univention-join. That call does not redirect its stderr output to stdin, the following happens:

A new appbox docker image was created. When that image joins, the call to hostname fails with 

hostname: you must be root to change the host name

The problem is, that the appcenter catches this output, and displays it as an error popup at the end of each app installation; i.e. for apps that use the 4.1-4 appbox image and download the new version.

+++ This bug was initially created as a clone of Bug #39068 +++
Comment 1 Felix Botner univentionstaff 2017-01-31 10:14:45 CET
Added >>/var/log/univention/join.log 2>&1 in univention-join to hostname call.
univention-join.yaml 

(merged to 4.2-0)

also added test 80_docker/40_app_umc_install_latest_appbox, this tests 
 * tries to find the latest appbox tag (4.1-4 currently)
 * creates a local app with this appbox image version
 * installs the app via python umctest
 * fails if there are 'WARNING', 'ERROR', 'CRITICAL' messages during the 
   installation

At the moment the test fails with "hostname: you must be root to change the host name" (due to this bug), but once this is fixed and the 4.1-4 basec appbox image is updated, the test should be good.
Comment 2 Philipp Hahn univentionstaff 2017-02-07 17:11:29 CET
~OK: ucs-4.2-0@76217 → needs debian/changelog and build
OK: ucs-4.2-0@76212 tests/80_docker/40_app_umc_install_latest_appbox
OK: ucs-4.1-4@76215 YAML
OK: ucs-4.1-4@76216 univention-join
OK: ucs-4.1-4@76243 YAML
OK: ucs-4.1-4@76248 YAML
OK: ucs-4.1-4@76211 tests/80_docker/40_app_umc_install_latest_appbox

OK: errata-announce -V --only univention-join.yaml
OK: univention-join.yaml
Comment 3 Janek Walkenhorst univentionstaff 2017-02-08 14:22:55 CET
<http://errata.software-univention.de/ucs/4.1/387.html>