Bug 43402 - unable to install UCS Backup, Slave or Member without a valid UCS domain DNS
unable to install UCS Backup, Slave or Member without a valid UCS domain DNS
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
: 44174 44580 (view as bug list)
Depends on: 43816
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-23 17:40 CET by Tobias Birkefeld
Modified: 2017-08-09 17:29 CEST (History)
10 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Ticket number: 2017051921000162, 2017080921000658
Bug group (optional):
Max CVSS v3 score:


Attachments
validation failed (28.34 KB, image/png)
2017-01-23 17:41 CET, Tobias Birkefeld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Birkefeld univentionstaff 2017-01-23 17:40:38 CET
Due a validation error in system setup (see screenshot), it is not possible to install a UCS Backup, Slave or Memberserver without a valid UCS domain DNS. For the sake of completeness: join after installation is deselected -> so no domain join will be performed.

Following error is shown:
The specified nameserver 8.8.8.8 is not part if a valid UCS domain.

Do following steps to reproduce the error:
In network settings choose any DNS server (eg. 8.8.8.8). At "Domain setup" select "Join into an existing UCS domain" and deselect "Start join at the end of the installation". Go further and after the "Software configuration" screen, there will be shown the validation error.

I think this validation should not be made, if the user deselect "Start join at the end of the installation". There is no need for this.


You need this installation path for "Cool Solution - Run a virtualized Domain Controller Master with UVMM".
Also an installation without connection to another UCS system of the UCS domain is not possible.
Comment 1 Tobias Birkefeld univentionstaff 2017-01-23 17:41:21 CET
Created attachment 8370 [details]
validation failed
Comment 2 Philipp Hahn univentionstaff 2017-03-31 09:47:55 CEST
*** Bug 44174 has been marked as a duplicate of this bug. ***
Comment 3 Tobias Birkefeld univentionstaff 2017-05-11 09:00:24 CEST
*** Bug 44580 has been marked as a duplicate of this bug. ***
Comment 4 Johannes Keiser univentionstaff 2017-06-26 14:22:52 CEST
r 80479
univention-system-setup (10.0.10-20) 
Bug #43402:
* do not validate nameserver when joining into an existing
UCS domain and 'Start join at the end of the installation' is set to false
* add missing basic latin special characters to umlauts dict

r 80480
univention-web (1.0.42-20) 
* Bug #43402: fix disabled text boxes in UMC cards being not
distinguishable

------
The build of univention-system-setup is currently blocked by Bug #43816
Comment 5 Johannes Keiser univentionstaff 2017-06-26 15:04:16 CEST
univention-system-setup successfully build
Comment 6 Florian Best univentionstaff 2017-06-27 14:43:30 CEST
REOPEN: Missing YAML files!
Comment 7 Johannes Keiser univentionstaff 2017-06-27 15:18:14 CEST
(In reply to Florian Best from comment #6)
> REOPEN: Missing YAML files!

YAML: r 80530
Comment 8 Florian Best univentionstaff 2017-06-27 16:53:55 CEST
OK: the nameserver is not enforced if the system is not going to be joined.
YAML: OK (adjusted in r80532)
Comment 9 Janek Walkenhorst univentionstaff 2017-06-28 13:11:51 CEST
univention-system-setup.desc.line.1 (from univention-system-setup)
line length
Comment 11 Arvid Requate univentionstaff 2017-07-04 14:10:47 CEST
A partner asked if it would be possible to provide updated ISO images, otherwise the erratum is of no use to him.
Comment 12 Nico Stöckigt univentionstaff 2017-08-09 17:29:49 CEST
Another customer requested updated ISO's.