Bug 43478 - Post-Installation of Samba4 in UCS@School headquarters fails, tries to join into school DC
Post-Installation of Samba4 in UCS@School headquarters fails, tries to join i...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 4.1
Other Linux
: P1 normal (vote)
: UCS 4.2-0-errata
Assigned To: Arvid Requate
Felix Botner
:
: 30131 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-02 11:42 CET by Arvid Requate
Modified: 2017-09-22 15:03 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Troubleshooting, Workaround is available
Max CVSS v3 score:
best: Patch_Available+


Attachments
improve_s4_connector_detection.diff (5.47 KB, patch)
2017-02-02 11:42 CET, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-02-02 11:42:56 CET
Created attachment 8396 [details]
improve_s4_connector_detection.diff

If Samba/AD shall be installed later on the UCS@school Master in a Multiserver environment, after UCS@school Samba/AD DC Slaves have been joined, then it is important to set these two UCR variables first:


ucr set samba4/provision/primary=yes \
        connector/s4/allow/secondary=yes

Otherwise the univention-samba4 joinscript will attempt to join into a school.

The attached patch should improve the detection of the S4-Connector, so that it "just works" and manual setting of the UCR variable is not required. This is a) good for UCS@school and b) simplifies the code a bit in both, the samba4 and the s4connector join scripts.


+++ This bug was initially created as a clone of Bug #30131 +++

+++ This bug was initially created as a clone of Bug #40432 +++
Comment 1 Arvid Requate univentionstaff 2017-04-27 19:31:58 CEST
Package rebuilt with patch.

Advisory: univention-s4-connector.yaml
Comment 2 Stefan Gohmann univentionstaff 2017-05-06 19:52:19 CEST
The s4 connector script now uses univention-samba4 functions which have been added. The bug number is in both YAML files, so the update will be announced at once.

It won't work if univention-samba4 is already installed in the old version.  We've have had a similar situation in UCS 4.1.

So, I think we should update the dependency.
Comment 3 Arvid Requate univentionstaff 2017-06-01 19:05:09 CEST
Ok, dependency added.
Comment 4 Felix Botner univentionstaff 2017-06-14 16:56:45 CEST
OK - normal setup s4 master + s4 slave
OK - school master + school s4 slave 
    OK + s4 on master
    OK + new s4 school slave
OK - school s4 master + school s4 slave

FAIL s4 master + s4 backup 
 * "standalone" samba on backup (should join to master)
 * s4 connector is running (should not be started, already running on master)
Comment 5 Arvid Requate univentionstaff 2017-06-14 17:59:56 CEST
As discussed, I've replaces the ugly "samba-tool drs showrepl" detection (introduced for Bug #33399) by LDAP search filters adjusted for UCS@school.
Comment 6 Felix Botner univentionstaff 2017-06-14 18:32:31 CEST
OK - normal setup s4 master + s4 slave
OK - s4 school master + s4 school backup (joins into master, no s4 connector)

TODO - school master + school s4 slave 
    TODO + s4 on master
    TODO + new s4 school slave
TODO - school s4 master + school s4 slave
Comment 7 Felix Botner univentionstaff 2017-06-15 16:25:44 CEST
OK - school master + school s4 slave 
     OK + s4 on master
     OK + new s4 school slave
     OK + new s4 school backupp
OK - school s4 master + school s4 slave

OK - univention-s4-connector.yaml
OK - univention-samba4.yaml
Comment 9 Arvid Requate univentionstaff 2017-06-28 18:07:13 CEST
*** Bug 30131 has been marked as a duplicate of this bug. ***