Bug 43562 - udm policies/registry modify --remove 'foo bar' does not work
udm policies/registry modify --remove 'foo bar' does not work
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM - CLI
UCS 4.1
Other Linux
: P5 normal with 6 votes (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-16 12:30 CET by Florian Best
Modified: 2017-07-05 13:06 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Ticket number: 2016041921000291
Bug group (optional): API change, Cleanup, External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (1.39 KB, patch)
2017-02-16 12:30 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-02-16 12:30:13 CET
Created attachment 8429 [details]
patch

udm policies/registry modify --remove 'foo bar' does not work.
Internally the policies/registry handler works with tuples but the UDM CLI wants to remove a list from the currently set values.

Hotfix (API change) attached, better would be to solve also Bug #43286.
Comment 1 Florian Best univentionstaff 2017-02-16 12:34:19 CET
We don't really need this change if we fix Bug #43286 instead.
Comment 2 Philipp Hahn univentionstaff 2017-03-29 10:28:17 CEST
*** Bug 41072 has been marked as a duplicate of this bug. ***
Comment 3 Johannes Keiser univentionstaff 2017-06-29 16:55:10 CEST
(In reply to Florian Best from comment #0)
> Created attachment 8429 [details]
> patch
> 
> udm policies/registry modify --remove 'foo bar' does not work.
> Internally the policies/registry handler works with tuples but the UDM CLI
> wants to remove a list from the currently set values.
> 
> Hotfix (API change) attached, better would be to solve also Bug #43286.

Applied patch:

r 80644
univention-directory-manager-modules (12.0.17-29) 
* Bug #43562: Applied patch from Florian Best - Fix error in
udm policies/registry modify --remove
Comment 4 Johannes Keiser univentionstaff 2017-06-29 18:40:33 CEST
YAML: r 80656
Comment 5 Florian Best univentionstaff 2017-06-29 18:47:58 CEST
I added a test case:
r80657 | Bug #43562
Comment 6 Florian Best univentionstaff 2017-06-29 18:54:10 CEST
OK: fix
OK: YAML
Comment 7 Janek Walkenhorst univentionstaff 2017-07-05 13:06:35 CEST
<http://errata.software-univention.de/ucs/4.2/79.html>