Bug 43999 - Adjust styling of dialogs
Adjust styling of dialogs
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Johannes Keiser
Alexander Kläser
:
: 44285 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-21 12:56 CET by Alexander Kläser
Modified: 2017-09-20 15:03 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.029
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Design
Max CVSS v3 score:


Attachments
patch (50.04 KB, patch)
2017-08-30 13:29 CEST, Johannes Keiser
Details | Diff
Screenshot of setup wizard (in local mode of an appliance) (49.04 KB, image/png)
2017-09-15 13:45 CEST, Alexander Kläser
Details
Help dialogs with artifacts (35.01 KB, image/png)
2017-09-15 13:56 CEST, Alexander Kläser
Details
Styling error in dialog after installing app (109.33 KB, image/png)
2017-09-15 14:39 CEST, Alexander Kläser
Details
App Center cannot be opened in IE11 (211.94 KB, image/png)
2017-09-15 15:18 CEST, Alexander Kläser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2017-03-21 12:56:28 CET
From Bug 43528, comment 22:
> Created attachment 8460 [details]
> Inline dialog used in the App Center installation dialog
> 
> Dialogs:
> * We can have "inline" dialogs, e.g. for the installation wizard in the App
>   Center, Self Service, UCS@school wizard, UCC wizard... and maybe others?
>   Inline dialogs are non-modal and offer a frame for pages with few content.
> * Dialogs (and inline dialogs) should have flat buttons with the default button
>   being colored (in the normal dialogs the color should be the UCS default green)
> * To unify the look of inline and normal dialogs, we should to remove the dark 
>   header + close button according to the GMD style.

From Bug 43528, comment 23:
> Created attachment 8461 [details]
> Self service
> 
> We need to adjust the padding in the self service and use the unified style
> for inline dialogs.
Comment 1 Alexander Kläser univentionstaff 2017-04-04 15:22:15 CEST
*** Bug 44285 has been marked as a duplicate of this bug. ***
Comment 2 Johannes Keiser univentionstaff 2017-08-30 13:29:09 CEST
Created attachment 9156 [details]
patch
Comment 3 Johannes Keiser univentionstaff 2017-08-30 15:19:00 CEST
(In reply to Johannes Keiser from comment #2)
> Created attachment 9156 [details]
> patch

Waiting for the UCS 4.2-2 release before applying the patch
Comment 4 Johannes Keiser univentionstaff 2017-09-13 20:01:49 CEST
(In reply to Johannes Keiser from comment #3)
> (In reply to Johannes Keiser from comment #2)
> > Created attachment 9156 [details]
> > patch
> 
> Waiting for the UCS 4.2-2 release before applying the patch

Applied patch:
cd6962b0
  Bug #43999: Adjust styling of Dialogs

Added yaml files: 20639034
Added debian changelog entries: a6962b0f
Updates yaml files with version numbers: 69b0cb37
Comment 5 Alexander Kläser univentionstaff 2017-09-15 13:45:24 CEST
Created attachment 9209 [details]
Screenshot of setup wizard (in local mode of an appliance)

The setup wizard looks good. However, in local mode the CSS class umcInlineDialog is removed from the wizard appliance which leads to not enough space for the page header.
Comment 6 Alexander Kläser univentionstaff 2017-09-15 13:56:57 CEST
Created attachment 9210 [details]
Help dialogs with artifacts

I noticed that some of the help dialogs show some artifacts.
Comment 7 Alexander Kläser univentionstaff 2017-09-15 14:39:47 CEST
Created attachment 9211 [details]
Styling error in dialog after installing app

I installed the self service app and saw the illustrated dialog. There seems to be some styling issue with the headers. The dialog displays a README file of the app. This README file may contain headers
Comment 8 Alexander Kläser univentionstaff 2017-09-15 15:18:12 CEST
Created attachment 9212 [details]
App Center cannot be opened in IE11

I could not open the App Center module in IE11 (Win10) as some JS error occurred.
Comment 9 Johannes Keiser univentionstaff 2017-09-15 18:00:55 CEST
(In reply to Alexander Kläser from comment #5)
> Created attachment 9209 [details]
> Screenshot of setup wizard (in local mode of an appliance)
> 
> The setup wizard looks good. However, in local mode the CSS class
> umcInlineDialog is removed from the wizard appliance which leads to not
> enough space for the page header.

4ab2c3e27ca154c76c1d9e45a3e34959541a104c
Bug #43999: Adjust styling for setup wizard in local mode

(In reply to Alexander Kläser from comment #6)
> Created attachment 9210 [details]
> Help dialogs with artifacts
> 
> I noticed that some of the help dialogs show some artifacts.

844cc2c4dc5d2aa5fec3330e3863cf13bf65b09d
Bug #43999: Remove collision between identically named css classes

(In reply to Alexander Kläser from comment #7)
> Created attachment 9211 [details]
> Styling error in dialog after installing app
> 
> I installed the self service app and saw the illustrated dialog. There seems
> to be some styling issue with the headers. The dialog displays a README file
> of the app. This README file may contain headers

ba54846a3c1a5d7eb089297f2fff016b39237f31
Bug #43999: Prevent overflowing margins

043493a6c08258fa18fb9f07d4ead6a52369d68f
Bug #43999: Improve styling of AppConfigDialog

---
b4eae11596ed4742fbc16398985a85642b2b2ff9
Bug #43999: Add debian changelog entries
-----


(In reply to Alexander Kläser from comment #8)
> Created attachment 9212 [details]
> App Center cannot be opened in IE11
> 
> I could not open the App Center module in IE11 (Win10) as some JS error
> occurred.

Works for me.
Comment 10 Alexander Kläser univentionstaff 2017-09-18 11:02:36 CEST
(In reply to Johannes Keiser from comment #9)
> (In reply to Alexander Kläser from comment #5)
> > Created attachment 9209 [details]
> > Screenshot of setup wizard (in local mode of an appliance)
> > 
> > The setup wizard looks good. However, in local mode the CSS class
> > umcInlineDialog is removed from the wizard appliance which leads to not
> > enough space for the page header.
> 
> 4ab2c3e27ca154c76c1d9e45a3e34959541a104c
> Bug #43999: Adjust styling for setup wizard in local mode

OK, looks good.

> (In reply to Alexander Kläser from comment #6)
> > Created attachment 9210 [details]
> > Help dialogs with artifacts
> > 
> > I noticed that some of the help dialogs show some artifacts.
> 
> 844cc2c4dc5d2aa5fec3330e3863cf13bf65b09d
> Bug #43999: Remove collision between identically named css classes

OK.

> (In reply to Alexander Kläser from comment #7)
> > Created attachment 9211 [details]
> > Styling error in dialog after installing app
> > 
> > I installed the self service app and saw the illustrated dialog. There seems
> > to be some styling issue with the headers. The dialog displays a README file
> > of the app. This README file may contain headers
> 
> ba54846a3c1a5d7eb089297f2fff016b39237f31
> Bug #43999: Prevent overflowing margins
> 
> 043493a6c08258fa18fb9f07d4ead6a52369d68f
> Bug #43999: Improve styling of AppConfigDialog
> 
> ---
> b4eae11596ed4742fbc16398985a85642b2b2ff9
> Bug #43999: Add debian changelog entries
> -----

OK, looks fine now.

> (In reply to Alexander Kläser from comment #8)
> > Created attachment 9212 [details]
> > App Center cannot be opened in IE11
> > 
> > I could not open the App Center module in IE11 (Win10) as some JS error
> > occurred.
> 
> Works for me.

Hm, true... it also works for me now.

→ VERIFIED