Bug 44036 - App Status shows "Different UCS version" for Docker Apps
App Status shows "Different UCS version" for Docker Apps
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Eduard Mai
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-23 06:06 CET by Stefan Gohmann
Modified: 2017-07-13 15:37 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.057
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
umc-appcenter-domainwide-docker.png (67.43 KB, image/png)
2017-03-23 06:10 CET, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2017-03-23 06:06:13 CET
I've installed Horde on a DC Slave. On the Master, the App Center shows the status: "Different UCS version. Limited manageability". DC Master and DC Slave are installed with UCS 4.2.
Comment 1 Stefan Gohmann univentionstaff 2017-03-23 06:10:12 CET
Created attachment 8623 [details]
umc-appcenter-domainwide-docker.png
Comment 2 Dirk Wiesenthal univentionstaff 2017-03-29 13:09:00 CEST
The problem is this test in App.js:

if (!item.isLocal() && item.ucsVersion != this.ucsVersion) {
	ihost.appStatus = _('Different UCS Version. Limited manageability');
}

item.ucsVersion is set to "4.2" because this is the UCS version of the host. But this.ucsVersion refers to the App itself. And some Docker Apps are 4.1-Apps, thus this.ucsVersion is "4.1".

We should instead test against umc.tools.status('version/version').
Comment 3 Eduard Mai univentionstaff 2017-06-26 14:16:54 CEST
r80489 | Bug #44036: proper check against UCS version in App install status list
Comment 4 Dirk Wiesenthal univentionstaff 2017-06-26 16:09:13 CEST
There is a ")" missing in the patch. Also, "umc" is not defined. Just use "tools".
Comment 5 Eduard Mai univentionstaff 2017-06-26 17:43:52 CEST
r80503 | fixes typo
Comment 6 Dirk Wiesenthal univentionstaff 2017-06-27 14:10:11 CEST
YAML entry is missing
Comment 7 Eduard Mai univentionstaff 2017-06-28 11:37:05 CEST
r80543 | Bug #44036: yaml
Comment 8 Dirk Wiesenthal univentionstaff 2017-07-11 13:04:07 CEST
OK, works
Comment 9 Janek Walkenhorst univentionstaff 2017-07-13 15:37:53 CEST
<http://errata.software-univention.de/ucs/4.2/96.html>