Bug 44061 - univention-welcome-screen does not work on virtualbox and vmware
univention-welcome-screen does not work on virtualbox and vmware
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Jürn Brodersen
Erik Damrose
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-24 10:55 CET by Erik Damrose
Modified: 2017-07-26 14:39 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.309
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Appliance, External feedback, Usability
Max CVSS v3 score:


Attachments
system without welcome screen after system-setup (20.39 KB, image/png)
2017-03-31 14:53 CEST, Erik Damrose
Details
univention-welcome-screen.png (162 bytes, image/png)
2017-04-10 18:19 CEST, Erik Damrose
Details
0.9.2~23: seat: be a little more forgiving in the case there's no open terminal (1.69 KB, patch)
2017-06-21 12:04 CEST, Philipp Hahn
Details | Diff
welcome screen with patch from comment 5 (214.21 KB, image/png)
2017-06-21 12:07 CEST, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2017-03-24 10:55:14 CET
Plymouth and subsequently the welcome screen do not work on virtualbox. The same logfile is produced as on the original bug, when plymouthd is started with --debug --no-daemon

https://forge.univention.org/bugzilla/attachment.cgi?id=8557

+++ This bug was initially created as a clone of Bug #43656 +++
Comment 1 Erik Damrose univentionstaff 2017-03-31 14:53:26 CEST
Created attachment 8732 [details]
system without welcome screen after system-setup

On vmware and virtualbox the welcome screen is not displayed after system setup, see screenshot
Comment 2 Erik Damrose univentionstaff 2017-04-10 18:19:20 CEST
Created attachment 8767 [details]
univention-welcome-screen.png

It worked in VMware when i tested it with an interim version, but the UCS 4.2 release version does not show a welcome screen in any VMware version. The welcome screen is shown briefly, but then switches to a blank screen. I found, that our script renders a blank screen as the image in /tmp/.univention-welcome-screen.png, which is then displayed. May be pointless, but attached is the image found in /tmp/.univention-welcome-screen.png
Comment 3 Michael Grandjean univentionstaff 2017-04-25 09:04:26 CEST
Doesn't work either on Hyper-V (Windows Server 2012 R2). Bootsplash is not shown. Welcome screen is not shown, but instead of a blank screen, I see the login console.
Comment 4 Erik Damrose univentionstaff 2017-04-26 09:54:52 CEST
UCS users are confused by the warning messages: https://help.univention.com/t/boot-und-shutdown-error/5584
Comment 5 Philipp Hahn univentionstaff 2017-06-21 12:04:08 CEST
Created attachment 8945 [details]
0.9.2~23: seat: be a little more forgiving in the case there's no open terminal

# gdb --args plymouthd --attach-to-session --no-daemon --tty=/dev/tty8
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff79b71d0 in ply_terminal_is_open () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
(gdb) bt: /usr/lib/grub/x86_64-efi-signed/grubx64.efi.signed aus base/grub-efi-amd64-signed/gcdx64.efi.signed

#0  0x00007ffff79b71d0 in ply_terminal_is_open () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#1  0x00007ffff79bab8f in ply_seat_open () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#2  0x00007ffff79b1d36 in ?? () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#3  0x00007ffff79b21e4 in ?? () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#4  0x00007ffff79b2b1f in ?? () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#5  0x00007ffff79b2e44 in ?? () from /lib/x86_64-linux-gnu/libply-splash-core.so.2
#6  0x0000000000404d7b in main ()

Maybe <https://bugs.freedesktop.org/show_bug.cgi?id=80553> AKA <http://cgit.freedesktop.org/plymouth/commit/?id=84eb4381db85877a9a56b35994e6c10d43e46ebe>?
Comment 6 Erik Damrose univentionstaff 2017-06-21 12:07:54 CEST
Created attachment 8946 [details]
welcome screen with patch from comment 5

@Comment5: Great, plymouth does not crash anymore. We at least have a bootsplash and welcome screen. However, there still seem to be some redraw issues, see screenshot.
Comment 7 Jürn Brodersen univentionstaff 2017-07-03 16:04:47 CEST
Package: plymouth
Version: 0.9.0-9A~4.2.0.201707031208
Branch: ucs_4.2-0-errata4.2-1
Scope: errata4.2-1

r17559-17565

* The crash was fixed with the patch from comment 5.
* The graphic errors were fixed by making sure /dev/fb0 is considered an active console.
* The blank welcome screen (with vmware and at least intel hardware) was fixed by deactivating the drm renderer. It's not really possible to grab an image from plymouth if the drm renderer is used. It would be possible to just let plymouth running but it uses a noticeable amount of system resources. I did a quick research if disabling the drm renderer might become a problem, but it doesn't seem so. See for example: https://www.phoronix.com/scan.php?page=news_item&px=DRM-Text-Mode-Proposal

-----

Package: univention-bootsplash
Version: 8.0.0-12A~4.2.0.201707031225
Branch: ucs_4.2-0
Scope: errata4.2-1

r80756

* I removed the dependency on fbgrab and fbi by using "plymouth quit --retain-splash".
* The switch over to the welcome screen is now flicker free.
* Improved systemd integration.

-----

r80789: YAML
Comment 8 Jürn Brodersen univentionstaff 2017-07-03 16:22:37 CEST
I noticed that the console screen saver now seems to be ignored. Is that behaviour ok? See also Bug 40750. (Can be reproduced by adding consoleblank=10 to the kernel options)
Comment 9 Jürn Brodersen univentionstaff 2017-07-07 12:36:05 CEST
r80962: fix welcome screen start in appliance mode
Package: univention-system-setup
Version: 10.0.10-29A~4.2.0.201707071230
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 10 Erik Damrose univentionstaff 2017-07-14 11:47:30 CEST
As discussed, with the current version there are black tiles leaking and showing up in system, setup; reopening
Comment 11 Jürn Brodersen univentionstaff 2017-07-14 14:07:15 CEST
(In reply to Erik Damrose from comment #10)
> As discussed, with the current version there are black tiles leaking and
> showing up in system, setup; reopening

This happened due to a typo I made in bug 44952...
Comment 12 Erik Damrose univentionstaff 2017-07-19 12:23:07 CEST
OK: bootsplash and welcome-screen
OK: Transition after system-setup
OK: KVM, VMWare, Virtualbox, hardware(xen5)
OK: plymouth, univention-bootsplash, univention-system-setup
OK: Yaml
Verified