Bug 44153 - New printer shares not shown in Windows, only after additional samba reload
New printer shares not shown in Windows, only after additional samba reload
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Printserver
UCS 4.2
Other Linux
: P3 normal (vote)
: UCS 4.2-0-errata
Assigned To: Felix Botner
Arvid Requate
:
: 40426 (view as bug list)
Depends on: 44118
Blocks: 44653
  Show dependency treegraph
 
Reported: 2017-03-30 13:42 CEST by Arvid Requate
Modified: 2017-05-24 10:47 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
workaround_new_printer_not_shown_in_windows.patch (379 bytes, patch)
2017-03-30 13:42 CEST, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-03-30 13:42:03 CEST
New printer shares are not shown in Windows, only after an additional /etc/init.d/samba reload, see attached patch for a workaround.

I've experimented with other things, reloading cups and sleeping 30 seconds between lpadmin, cups reload and samba reload. In the end, only a double samba reload fixed the issue, a cups reload was not required between lpadmin and samba reload.

+++ This bug was initially created as a clone of Bug #44118 +++
Comment 1 Arvid Requate univentionstaff 2017-03-30 13:42:36 CEST
Created attachment 8692 [details]
workaround_new_printer_not_shown_in_windows.patch
Comment 2 Stefan Gohmann univentionstaff 2017-04-18 07:57:29 CEST
The Enterprise Customer affected flag is set but neither a Ticket number is referenced nor a Customer ID is set. Please set a Ticket number or a Customer ID. Otherwise the Enterprise Customer affected flag will be reset.
Comment 3 Arvid Requate univentionstaff 2017-04-24 14:02:46 CEST
*** Bug 40426 has been marked as a duplicate of this bug. ***
Comment 4 Felix Botner univentionstaff 2017-05-09 18:14:58 CEST
univention-printserver r79250

i also tested smbcontrol smbd reload-printers, but that did not work for me

univention-printserver.yaml
Comment 5 Arvid Requate univentionstaff 2017-05-22 20:59:35 CEST
Ok, works.
Comment 6 Janek Walkenhorst univentionstaff 2017-05-24 10:47:59 CEST
<http://errata.software-univention.de/ucs/4.2/21.html>