Bug 44213 - Apache configuration for univention-net-installer needs to be adapted to Apache 2.4
Apache configuration for univention-net-installer needs to be adapted to Apac...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Net Installer
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-0-errata
Assigned To: Philipp Hahn
Janek Walkenhorst
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-02 22:11 CEST by Stefan Gohmann
Modified: 2017-06-19 15:04 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.046
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2017-04-02 22:11:02 CEST
The univention-net-installer apache config is not yet converted to Apache 2.4. Thus, the net installert does not work.
Comment 1 Stefan Gohmann univentionstaff 2017-04-02 22:13:56 CEST
The following workaround will work:

Create the following file /etc/apache2/sites-available/univention-net-installer.conf:

Alias /univention-client-boot /var/lib/univention-client-boot
<Directory /var/lib/univention-client-boot>
        Options +Indexes +FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

Run 
 ~# a2ensite univention-net-installer.conf

And reload apache2:
 ~# service apache2 reload
Comment 2 Philipp Hahn univentionstaff 2017-04-24 10:11:57 CEST
r78872 | Bug #44213 pxe: Upgrade to Apache 2.4 syntax
r78875 | Bug #44213 pxe: Rename Apache 2.4 site
r78876 | Bug #44213 pxe: Rename Apache 2.4 site 2

Package: univention-net-installer
Version: 10.0.0-4A~4.2.0.201704240934
Version: 10.0.0-5A~4.2.0.201704241003
Version: 10.0.0-5A~4.2.0.201704241008
Branch: ucs_4.2-0
Scope: errata4.2-0

r78873 | Bug #44213 pxe: Upgrade to Apache 2.4 syntax YAML
r78877 | Bug #44213 pxe: Upgrade to Apache 2.4 syntax YAML 2
 univention-net-installer.yaml
Comment 3 Janek Walkenhorst univentionstaff 2017-06-16 14:20:08 CEST
Code review: OK
Advisory: Fixed typo
Tests: OK
Comment 4 Janek Walkenhorst univentionstaff 2017-06-19 15:04:51 CEST
<http://errata.software-univention.de/ucs/4.2/48.html>