Bug 44361 - Content Sorting should be mixed case
Content Sorting should be mixed case
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-0-errata
Assigned To: Jürn Brodersen
Florian Best
:
: 31219 34480 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-12 15:16 CEST by Nico Stöckigt
Modified: 2017-07-26 16:24 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.029
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017041221000444
Bug group (optional): External feedback, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Stöckigt univentionstaff 2017-04-12 15:16:22 CEST
The contents in the UMC are displayed A-Za-z which might be confusing; the behavior in 4.0 and 4.1 was accurate (aA-zZ).

This should be changed back to the used behavior of mixed case sorting.
Comment 1 Jürn Brodersen univentionstaff 2017-04-13 14:38:06 CEST
Version: 1.0.42-9A~4.2.0.201704131427
Branch: ucs_4.2-0
Scope: errata4.2-0
r78792: sort grid values using locale aware sorting
r78793: YAML

@Florian: I think bug 34480 and bug 31219 are duplicates of this bug and fixed by this patch. Could you take a look at them, too? Thanks
Comment 2 Florian Best univentionstaff 2017-04-24 13:51:57 CEST
*** Bug 34480 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2017-04-24 14:17:39 CEST
*** Bug 31219 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2017-04-24 14:35:18 CEST
OK: sorting works nice and locale aware (EN|DE)
OK: sorting of DNS reverse zones and IP addresses in pointer records

REOPEN: Please use require('dojo/_base/kernel').locale instead of dojo.locale.
Comment 5 Jürn Brodersen univentionstaff 2017-04-24 15:09:09 CEST
r78892: don't use global dojo variable
Package: univention-web
Version: 1.0.42-10A~4.2.0.201704241500
Branch: ucs_4.2-0
Scope: errata4.2-0

r78893: YAML
Comment 6 Florian Best univentionstaff 2017-04-24 17:34:16 CEST
OK: kernel.locale
OK: YAML
Comment 7 Janek Walkenhorst univentionstaff 2017-04-26 14:36:54 CEST
<http://errata.software-univention.de/ucs/4.2/4.html>