Bug 44370 - Normalize in user templates of names with umlauts do not work completely
Normalize in user templates of names with umlauts do not work completely
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 4.2
Other Linux
: P5 major (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
: 44367 (view as bug list)
Depends on: 44367
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-13 14:39 CEST by Tobias Birkefeld
Modified: 2017-06-28 15:33 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.286
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Birkefeld univentionstaff 2017-04-13 14:39:28 CEST
If you use <:umlauts> in user templates (example of primary mail address: <firstname>[0].<lastname><:strip><:umlauts>@demo.univention.de), there will be a problem with names like "Ýlang Mustermann".


+++ This bug was initially created as a clone of Bug #44367 +++

Import of "Ýlang Müstèrmánn" produce "?" in username and email address with default settings.

I think there are some umlauts missing in "class property" in /usr/share/pyshared/univention/admin/__init__.py

May be better to use something like unicodedata.normalize() (see https://docs.python.org/2/library/unicodedata.html#unicodedata.normalize) instead of hard coding UMLAUTS!
Comment 1 Daniel Tröder univentionstaff 2017-04-18 10:32:31 CEST
*** Bug 44367 has been marked as a duplicate of this bug. ***
Comment 2 Johannes Keiser univentionstaff 2017-06-20 19:50:40 CEST
univention-management-console-module-udm:

r 80357
univention-management-console-module-udm (7.0.10-5) 
* Bug #44370: Add missing basic latin umlauts for the 'umlauts' modifier in templates

YAML: r 80376

-------------

univention-directory-manager-modules:

r 80358
univention-directory-manager-modules (12.0.17-13) 
* Bug #44370: Use unicodedata.normalize to convert umlauts

YAML: r 80377
Comment 3 Florian Best univentionstaff 2017-06-21 19:44:48 CEST
I created a test script:

ucs-test-ucsschool (4.0.4-21):
r80400 | Bug #44370: add test case 219_import_users_umlauts
Comment 4 Florian Best univentionstaff 2017-06-21 19:47:49 CEST
For the YAML:
"Correctly normalize umlauts and special characters for the umlauts modifier in templates."

Might be better → "The <:umlauts> modifier in the templating mechanism of e.g. user templates now normalizes all characters."
Comment 5 Johannes Keiser univentionstaff 2017-06-22 15:01:05 CEST
(In reply to Florian Best from comment #4)
> For the YAML:
> "Correctly normalize umlauts and special characters for the umlauts modifier
> in templates."
> 
> Might be better → "The <:umlauts> modifier in the templating mechanism of
> e.g. user templates now normalizes all characters."

Adapted yaml: r 80418
Comment 6 Florian Best univentionstaff 2017-06-22 17:03:11 CEST
OK: fix for UCS@school importer
OK: fix for UMC user templates
OK: YAML