Bug 44384 - AttributeError: 'NoneType' object has no attribute 'name'
AttributeError: 'NoneType' object has no attribute 'name'
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-18 11:44 CEST by Florian Best
Modified: 2017-10-23 16:45 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.257
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017101821000592, 2017090221000338, 2017090421000987
Bug group (optional): External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-04-18 11:44:51 CEST
Version: 4.1-4 errata408 (Vahr)

Remark: https://github.com/owncloud/integration/issues/6#issuecomment-293833826

Traceback(dccbf64bacd1eb0ebee94a7f76336b44):
Die Ausführung des Kommandos appcenter/docker/progress ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 281, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/mixins.py", line 149, in progress
    ret = progress_obj.poll()
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 309, in _thread
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 340, in invoke_docker
    progress.title = _('%s: Running tests') % (app.name,)
AttributeError: 'NoneType' object has no attribute 'name'
Comment 1 Erik Damrose univentionstaff 2017-06-14 17:01:25 CEST
Occured again in https://help.univention.com/t/update-ucs-with-owncloud-9/5419/19
Comment 3 Erik Damrose univentionstaff 2017-09-05 15:33:28 CEST
Occured again on my instance:

Installed nextcloud on a just joined slave (via master UMC App Center). Afterwards, a nextcloud app update was shown, for the app i just installed. The traceback occured when clicking the Update button for the app on the slave.

Die Ausführung des Kommandos appcenter/docker/remote/progress ist fehlgeschlagen:



Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/management/console/base.py", line 249, in execute
    function.__func__(self, request, *args, **kwargs)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 440, in _response
    return list(function(self, iterator, *nones))
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 286, in _fake_func
    yield function(self, *args)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/__init__.py", line 364, in remote_progress
    return client.umc_command('appcenter/docker/progress', {'progress_id': remote_progress_id}).result
  File "/usr/lib/pymodules/python2.7/univention/lib/umc.py", line 272, in umc_command
    return self.request('POST', 'command/%s' % (path,), data, headers)
  File "/usr/lib/pymodules/python2.7/univention/lib/umc.py", line 297, in request
    return self.send(request)
  File "/usr/lib/pymodules/python2.7/univention/lib/umc.py", line 316, in send
    raise HTTPError(request, response, self.hostname)
HTTPError: 591 on slave422 (command/appcenter/docker/progress): {"status": 591, "message": "Die Ausf\u00fchrung des Kommandos appcenter/docker/progress ist fehlgeschlagen:\n\nTraceback (most recent call last):\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/base.py\", line 249, in execute\n    function.__func__(self, request, *args, **kwargs)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 318, in _response\n    result = _multi_response(self, request)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 192, in _response\n    return function(self, request)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 440, in _response\n    return list(function(self, iterator, *nones))\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 286, in _fake_func\n    yield function(self, *args)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/mixins.py\", line 149, in progress\n    ret = progress_obj.poll()\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 309, in _thread\n    result = _multi_response(self, request)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 192, in _response\n    return function(self, request)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 440, in _response\n    return list(function(self, iterator, *nones))\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py\", line 286, in _fake_func\n    yield function(self, *args)\n  File \"/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/__init__.py\", line 387, in invoke_docker\n    progress.title = _('%s: Running tests') % (app.name,)\nAttributeError: 'NoneType' object has no attribute 'name'\n", "location": "https://slave422/univention/command"}
Comment 4 Florian Best univentionstaff 2017-09-15 11:39:35 CEST
Version: 4.2-1 errata157 (Lesum)
Comment 5 Florian Best univentionstaff 2017-09-15 11:41:49 CEST
 Version: 4.2-1 errata144 (Lesum)
Comment 6 Dirk Wiesenthal univentionstaff 2017-09-21 21:07:02 CEST
This may happen in mixed appcenter / appcenter-test environments. Maybe in other situations? Anyway, fixed for all of them.

univention-appcenter 6.0.10-7A~4.2.0.201709212056
Comment 7 Felix Botner univentionstaff 2017-09-25 16:37:22 CEST
OK - code looks good, my test ok although i could not reproduce the issue
OK - YAML
Comment 8 Arvid Requate univentionstaff 2017-10-18 12:02:43 CEST
<http://errata.software-univention.de/ucs/4.2/199.html>