Bug 44387 - IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/lib/docker/overlay/…/merged/tmp/tmp.kHPI9tHVWV'
IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/lib/docker/ov...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-4-errata
Assigned To: Felix Botner
Dirk Wiesenthal
:
: 44463 (view as bug list)
Depends on: 43151
Blocks: 44501
  Show dependency treegraph
 
Reported: 2017-04-18 12:07 CEST by Florian Best
Modified: 2017-07-12 12:36 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 4: Will affect most installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.343
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2016120321000091, 2016122221000153, 2016122221000199, 2016122221000331, 2017021621000217, 2017021621000413, 2017021621000468, 2017021721000181, 2017021721000555, 2017041621000213, 2017041421000262, 2017041221001201, 2017041121000857, 2017040921000183
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments
appcenter.log (2.08 MB, text/plain)
2017-04-21 15:20 CEST, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-04-18 12:07:04 CEST
Seems not fixed.

+++ This bug was initially created as a clone of Bug #43151 +++

Version: 4.1-4 errata350 (Vahr)

Traceback(66ab21b01bd57cdc050e13e117734c49):
Die Ausführung des Kommandos appcenter/docker/progress ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 281, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/mixins.py", line 149, in progress
    ret = progress_obj.poll()
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 309, in _thread
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 397, in invoke_docker
    result['success'] = action.call(app=app, username=self.username, password=self.password, **kwargs)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 183, in call
    return obj.call_with_namespace(namespace)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 189, in call_with_namespace
    result = self.main(namespace)
  File "%PY2.7%/univention/appcenter/actions/remove.py", line 48, in main
    return self.do_it(args)
  File "%PY2.7%/univention/appcenter/actions/install_base.py", line 108, in do_it
    self._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 49, in _do_it
    super(Remove, self)._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/remove.py", line 54, in _do_it
    self._remove_app(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 55, in _remove_app
    self._remove_docker_container(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 59, in _remove_docker_container
    if self._backup_container(app, backup_data='move') is False:
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 74, in _backup_container
    if not self._store_data(app):
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 62, in _store_data
    process = self._execute_container_script(app, 'store_data', _credentials=False)
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 132, in _execute_container_script
    with open(docker.path(error_file), 'r+b') as error_handle:
IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/lib/docker/overlay/c3560ded3e68efa1c6386decd48fdef39fdeb48033e6d6c5d7282e7fb53dc1dc/merged/tmp/tmp.kHPI9tHVWV'
Comment 1 Florian Best univentionstaff 2017-04-18 12:09:52 CEST
Version: 4.2-0 errata0 (Lesum)
Version: 4.1-4 errata408 (Vahr)

Tickets (doesn't fit into the field anymore):
2017041621000213, 2017041421000262, 2017041221001201, 2017041121000857, 2017040921000183, 2017040821000292, 2017040721000347, 2017040721000329, 2017040621001026, 2017040621000714
Comment 2 Florian Best univentionstaff 2017-04-18 12:11:54 CEST
Execution of command 'appcenter/docker/progress' has failed:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 281, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/mixins.py", line 149, in progress
    ret = progress_obj.poll()
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 309, in _thread
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 371, in invoke_docker
    result['success'] = action.call(app=app, username=self.username, password=self.password, **kwargs)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 185, in call
    return obj.call_with_namespace(namespace)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 191, in call_with_namespace
    result = self.main(namespace)
  File "%PY2.7%/univention/appcenter/actions/remove.py", line 49, in main
    return self.do_it(args)
  File "%PY2.7%/univention/appcenter/actions/install_base.py", line 109, in do_it
    self._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 50, in _do_it
    super(Remove, self)._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/remove.py", line 55, in _do_it
    self._remove_app(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 56, in _remove_app
    self._remove_docker_container(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_remove.py", line 60, in _remove_docker_container
    if self._backup_container(app, backup_data='move') is False:
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 75, in _backup_container
    if not self._store_data(app):
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 63, in _store_data
    process = self._execute_container_script(app, 'store_data', _credentials=False)
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 111, in _execute_container_script
    with docker.tmp_file() as error_file:
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "%PY2.7%/univention/appcenter/docker.py", line 272, in tmp_file
    tmp_file = NamedTemporaryFile(dir=tmp_dir)
  File "/usr/lib/python2.7/tempfile.py", line 454, in NamedTemporaryFile
    (fd, name) = _mkstemp_inner(dir, prefix, suffix, flags)
  File "/usr/lib/python2.7/tempfile.py", line 235, in _mkstemp_inner
    fd = _os.open(file, flags, 0600)
OSError: [Errno 2] No such file or directory: '/var/lib/docker/overlay/961be00512b13af6b5d3b055478c618d65b61c3c32c4a4c07480e4912ce266ff/merged/tmp/tmpqOtkds'
Comment 3 Florian Best univentionstaff 2017-04-18 16:47:07 CEST
2017041821000308
2017032921000736
2017040521000011
2017040321000818

Version: 4.1-4 errata408 (Vahr)

Remark: NextCloud Konnte leider nicht installiert werden!
Comment 4 Florian Best univentionstaff 2017-04-18 16:59:50 CEST
Remark: nextcloud sollte deinstalliert werden

Version: 4.1-4 errata406 (Vahr)

Remark: THIS IS SO UNSTABLE.
SHUTDOWN AND RESTART OF UNIVENTION SERVER CAUSES DOCKER IMAGE CONTAINER TO BE UNABLE TO START. SO FRUSTRATING>
FIX THIS

2017022621000332
2017030421000229
2017022721000616
2017022721000581
2017022521000147
2017022421000078
2017022721000572
2017031621000841
2017022721000591
2017030221000456
2017031521000333
2017022721000563
2017030321000811
2017031521000119
2017022721000607
Comment 5 Florian Best univentionstaff 2017-04-18 17:01:24 CEST
Reported 38 times until now!
Comment 6 Florian Best univentionstaff 2017-04-21 11:15:45 CEST
Reported again, 4.1-4 errata407 (Vahr)

2017032721000061
Comment 7 Florian Best univentionstaff 2017-04-21 14:55:52 CEST
2017041921000977
Version: 4.2-0 errata2 (Lesum)
Comment 8 Florian Best univentionstaff 2017-04-21 14:56:00 CEST
2017041921000799

Version: 4.2-0 errata2 (Lesum)

Remark: bei der Installation von Horde Groupware kommt dieser Fehler. Andere Docker Images funktionieren jedoch
Comment 9 Florian Best univentionstaff 2017-04-21 15:17:46 CEST
2017041821000773
Version: 4.2-0 errata0 (Lesum)

Remark: Wollte nextcloud über das APP-Center updaten
Comment 10 Florian Best univentionstaff 2017-04-21 15:19:03 CEST
2017032221000151
Version: 4.2-0 errata0 (Lesum)

Remark: UCS 4.2 RC, erste Installation von Etherpad: join fehlgeschlagen. zweite Installation: dieser traceback
Comment 11 Florian Best univentionstaff 2017-04-21 15:20:01 CEST
Created attachment 8797 [details]
appcenter.log
Comment 12 Florian Best univentionstaff 2017-04-21 15:21:03 CEST
2017032121000671
Version: 4.2-0 errata0 (Lesum)

Remark: Hallo Stefan, wie eben per Mail von Dir gewünscht, hier die Python-Exception bei der Ethernet-Installation. Gruß, Peter
Comment 13 Florian Best univentionstaff 2017-04-21 15:21:39 CEST
2017031921000193
Version: 4.1-4 errata407 (Vahr)
Comment 14 Florian Best univentionstaff 2017-04-21 15:23:09 CEST
2017031521000333
Version: 4.1-4 errata406 (Vahr)

es handelte sich um die Nextcloud…
…jetzt installiert, jedoch hat mein „Administrator“
keinerlei admin-Rechte in der Nextcloud…
Comment 15 Florian Best univentionstaff 2017-04-21 16:32:07 CEST
2017041521000224

UCS Version: 4.2-0 errata1 (Lesum)
Comment 16 Florian Best univentionstaff 2017-04-24 20:41:06 CEST
*** Bug 44463 has been marked as a duplicate of this bug. ***
Comment 17 Florian Best univentionstaff 2017-04-27 12:05:57 CEST
Reported 5 times again (4.2-0 errata2/4 (Lesum)):

2017042521000214
2017042521000572
2017042121000721
2017042621000392
2017042621000589
Comment 18 Florian Best univentionstaff 2017-04-28 07:32:23 CEST
2017042721001362
Version: 4.2-0 errata0 (Lesum)
Comment 19 Felix Botner univentionstaff 2017-04-28 14:08:49 CEST
as discussed, we create tmp files in another directory (/var/univention/tmp) to avoid conflict with the tmp cleanup process.

univention-appcenter r78985
errata4.1-4 univention-appcenter.yaml
Comment 20 Florian Best univentionstaff 2017-04-28 14:11:14 CEST
2017042821000389
4.1-4 errata408 (Vahr)
Comment 21 Dirk Wiesenthal univentionstaff 2017-05-03 04:25:08 CEST
Install with forced /tmp/ clear: OK
Changeset: OK
YAML: OK
Comment 22 Janek Walkenhorst univentionstaff 2017-05-03 15:37:13 CEST
<http://errata.software-univention.de/ucs/4.1/412.html>
Comment 23 Florian Best univentionstaff 2017-06-23 17:33:56 CEST
Reported again, 4.2-0 errata1 (Lesum)
OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/lib/docker/overlay/8f8649ad966c0d6caa230e9873da1612355f915de8c744953fa306544ba9b847/merged/tmp/tmpARJiGz'
Ticket#2017062321000581