Bug 44507 - univention-bacula: unmet dependencies
univention-bacula: unmet dependencies
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Backup - bacula
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-0-errata
Assigned To: Felix Botner
Philipp Hahn
:
Depends on: 44451 44592
Blocks: 45082
  Show dependency treegraph
 
Reported: 2017-04-30 10:39 CEST by Michael Grandjean
Modified: 2017-07-26 18:06 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.137
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2017-04-30 10:39:27 CEST
root@ucs29:~# univention-app info
UCS: 4.2-0 errata4
App Center compatibility: 4
Installed: adtakeover=4.0.0 dhcp-server=11.0.0 radius=4.0 samba4=4.6
Upgradable:

Upgraded from 4.1 with manually installed univention-postgresql


root@ucs29:~# univention-install univention-bacula
[...]
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 univention-bacula : Depends: bacula but it is not going to be installed
                     Depends: bacula-server but it is not going to be installed
                     Depends: bacula-director-pgsql but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Comment 1 Felix Botner univentionstaff 2017-05-02 11:56:26 CEST
hmm, works for me

UCS master 4.1, installed adtakeover, dhcp-server, radius, samba4 and 
univention-postgresql. 

Update to 4.2

-> univention-app info
UCS: 4.2-0 errata4
App Center compatibility: 4
Installed: adtakeover=4.0.0 dhcp-server=11.0.0 radius=4.0 samba4=4.6
Upgradable:

-> apt-get install univention-bacula
...
bacula-sd-pgsql (5.2.6+dfsg-9.A~4.2.0.201702161323) wird eingerichtet ...^M
bacula-server (5.2.6+dfsg-9.A~4.2.0.201702161323) wird eingerichtet ...^M
bacula-console (5.2.6+dfsg-9.A~4.2.0.201702161323) wird eingerichtet ...^M
bacula-fd (5.2.6+dfsg-9.A~4.2.0.201702161323) wird eingerichtet
...

-> dpkg -l| grep bacula
ii  bacula                                              5.2.6+dfsg-9.A~4.2.0.201702161323              all          network backup service - metapackage
ii  bacula-client                                       5.2.6+dfsg-9.A~4.2.0.201702161323              all          network backup service - client metapackage
ii  bacula-common                                       5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - common support files
ii  bacula-common-pgsql                                 5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - PostgreSQL common files
ii  bacula-console                                      5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - text console
ii  bacula-director-common                              5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - Director common files
ii  bacula-director-pgsql                               5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - PostgreSQL storage for Director
ii  bacula-fd                                           5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - file daemon
ii  bacula-sd                                           5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - storage daemon
ii  bacula-sd-pgsql                                     5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - PostgreSQL SD tools
ii  bacula-server                                       5.2.6+dfsg-9.A~4.2.0.201702161323              all          network backup service - server metapackage
ii  bacula-traymonitor                                  5.2.6+dfsg-9.A~4.2.0.201702161323              amd64        network backup service - tray monitor
ii  univention-bacula                                   8.0.0-4A~4.2.0.201703281910                    all          UCS - Bacula package

Is this machine still online?
Comment 2 Felix Botner univentionstaff 2017-05-02 14:00:16 CEST
My test system had postgresql-client (9.1+134.23.201409242249) installed and this fulfilled the dependencies for bacula-director-pgsql (and univention-bacula).

But if postgresql-client is NOT installed, the latest version can not be installed due to dependency errors:

-> postgresql-client:
  Installiert:           9.1+134.23.201409242249
  Installationskandidat: 9.4+165+deb8u2A~4.2.0.201703021601
  Versionstabelle:
     9.4+165+deb8u2A~4.2.0.201703021601 0
        500 https://updates.software-univention.de/4.2/maintained/ 4.2-0/all/ Packages
 *** 9.1+134.23.201409242249 0
        500 https://updates.software-univention.de/4.0/maintained/ 4.0-0/all/ Packages
        100 /var/lib/dpkg/status

-> apt-get -s install postgresql-client
The following packages have unmet dependencies:
 postgresql-client : Depends: postgresql-client-9.4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

-> apt-get -s install postgresql-client-9.4
The following packages have unmet dependencies:
 postgresql-client-9.4 : Depends: libpq5 (>= 9.4.10) but 9.1.24-0.A~4.2.0.201703301214 is to be installed
E: Unable to correct problems, you have held broken packages.

-> apt-cache policy libpq5
libpq5:
  Installed: 9.1.24-0.A~4.2.0.201703301214
  Candidate: 9.1.24-0.A~4.2.0.201703301214
  Version table:
 *** 9.1.24-0.A~4.2.0.201703301214 0
        500 https://updates.software-univention.de/4.2/maintained/ 4.2-0/amd64/ Packages


But in debian jessie libpq5 9.4.10-0+deb8u1 is the latest version. So we need to import libpq5 from jessie!
Comment 3 Felix Botner univentionstaff 2017-05-02 14:11:45 CEST
strange:

-> mirror/ftp/4.2-> find| grep libpq5
./maintained/4.2-0/i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
./maintained/4.2-0/amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb

-> apt/ucs_4.2-0-> find| grep libpq5
./i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
./amd64/libpq5_9.4.10-0+deb8u1_amd64.deb
./amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb

anyway, we need to rebuild postgresql-9.4 for 4.2
Comment 4 Felix Botner univentionstaff 2017-05-09 13:06:53 CEST
OK, postgresql-9.4 9.4.10 is no longer available, we need to build/synchronize the postgresql-9.4 9.4.11 packages for errata4.2-0. As we already have a bug to synchronize the debian point update (with the new postgresql-9.4 9.4.11 packages) we should wait here.
Comment 5 Felix Botner univentionstaff 2017-05-11 11:55:30 CEST
Copied postgresql-9-4 9.4.11-0+deb8u2 source i386 and amd64 packages to errata4.2-0.

ucs-4.2-0/doc/errata/staging/postgresql-9.4.yaml
Comment 6 Philipp Hahn univentionstaff 2017-05-12 19:39:53 CEST
(In reply to Felix Botner from comment #4)
> OK, postgresql-9.4 9.4.10 is no longer available, we need to
> build/synchronize the postgresql-9.4 9.4.11 packages for errata4.2-0.

FYI: The missing package files are still available from <http://snapshot.debian.org/package/postgresql-9.4/9.4.11-0%2Bdeb8u1/>
Comment 7 Philipp Hahn univentionstaff 2017-05-12 20:30:57 CEST
OK: apt-get install postgresql-client # 9.4+165+deb8u2A~4.2.0.201703021601
OK: postgresql-9.4.yaml
(OK): errata-announce -V --only postgresql-9.4.yaml

FYI: The announcement is blocked because we don't get the required .changes file; announce-errata requires it to get the list of files to announce.

FYI: I had to spend many hour on fixing our build system: Currently the state between apt/ and mirror/ftp/ is inconsistent; for example

mirror/ftp/4.2/maintained/4.2-0/i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
mirror/ftp/4.2/maintained/4.2-0/amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb
mirror/testing/4.2/maintained/4.2-0/i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
mirror/testing/4.2/maintained/4.2-0/amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb
test_mirror/ftp/4.2/maintained/4.2-0/i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
test_mirror/ftp/4.2/maintained/4.2-0/amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb
 this is on our public mirros

apt/ucs_4.2-0/i386/libpq5_9.1.24-0.A~4.2.0.201703301214_i386.deb
apt/ucs_4.2-0/amd64/libpq5_9.1.24-0.A~4.2.0.201703301214_amd64.deb
 the files are also in our internal repository

temp/ucs_4.2-0/libpq5_9.4.10-0+deb8u1_i386.deb
temp/ucs_4.2-0/libpq5_9.4.10-0+deb8u1_amd64.deb
 those were also in apt/ and should have been picked when UCS-4.2-0 was announced

apt/ucs_4.2-0-errata4.2-0/i386/libpq5_9.4.11-0+deb8u2_i386.deb
apt/ucs_4.2-0-errata4.2-0/amd64/libpq5_9.4.11-0+deb8u2_amd64.deb
 there are the new files for the errata

Currently we have
 find i386 amd64 all -maxdepth 1 -mindepth 1 | cut -d_ -f1 | sort | uniq -d | wc -l
 679
packages with duplicate versions! See Bug #44590 for more details.
Comment 8 Philipp Hahn univentionstaff 2017-05-22 11:06:06 CEST
REOPEN-RESOLVED-VERIFIED: postgresql-doc-9.4 was missing (found while working on Bug #44592)
Comment 9 Janek Walkenhorst univentionstaff 2017-05-24 10:48:02 CEST
<http://errata.software-univention.de/ucs/4.2/23.html>