Bug 44623 - UMC software update module fails to upgrade container environment of apps
UMC software update module fails to upgrade container environment of apps
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Eduard Mai
Dirk Wiesenthal
:
: 44759 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-17 16:09 CEST by Ingo Steuwer
Modified: 2017-08-30 16:29 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Screenshot of upgrade module with broken texts for app upgrade (45.04 KB, image/png)
2017-05-17 16:09 CEST, Ingo Steuwer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Steuwer univentionstaff 2017-05-17 16:09:00 CEST
Created attachment 8855 [details]
Screenshot of upgrade module with broken texts for app upgrade

UCS 4.2-0 Errata 15

I used the appliance mode to configure a DC Master and installed several apps (self service, etherpad, Nextcloud, OX, SuiteCRM).

The "Software Update" module in the UMC now lists two upgradeable apps, but the python string replacement is broken:

--
There are App Center updates available.

    %(name)s: Version %(old)s can be updated to %(new)s
    %(name)s: Version %(old)s can be updated to %(new)s
--

See also attached Screenshot.
Comment 1 Ingo Steuwer univentionstaff 2017-05-17 16:16:39 CEST
I was unable to update in the web interface, but univention-upgrade shows me some usefull information on the command line:

--
root@usm:~# univention-upgrade 

Starting univention-upgrade. Current UCS version is 4.2-0 errata15

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               found

The following apps can be upgraded:

SuiteCRM: The underlying container can be upgraded
Etherpad: The underlying container can be upgraded

Starting app upgrade                                   
Do you want to upgrade SuiteCRM [Y|n]? 
--

I was able to update the apps / container using univention-upgrade.
Comment 2 Michel Smidt univentionstaff 2017-05-23 17:42:01 CEST
(In reply to Ingo Steuwer from comment #0)
> Created attachment 8855 [details]
> Screenshot of upgrade module with broken texts for app upgrade
> 
> UCS 4.2-0 Errata 15
> 
> I used the appliance mode to configure a DC Master and installed several
> apps (self service, etherpad, Nextcloud, OX, SuiteCRM).
> 
> The "Software Update" module in the UMC now lists two upgradeable apps, but
> the python string replacement is broken:
> 
> --
> There are App Center updates available.
> 
>     %(name)s: Version %(old)s can be updated to %(new)s
>     %(name)s: Version %(old)s can be updated to %(new)s
> --
> 
> See also attached Screenshot.

Same here.
Comment 3 Erik Damrose univentionstaff 2017-06-12 11:48:22 CEST
*** Bug 44759 has been marked as a duplicate of this bug. ***
Comment 4 Dirk Wiesenthal univentionstaff 2017-06-30 09:52:29 CEST
Broken for Apps with "The underlying container can be upgraded". Other App updates are shown
Comment 5 Eduard Mai univentionstaff 2017-07-10 17:10:01 CEST
r81010 | Bug #44623: Properly display app updates when underlying docker containers were updated.
r81011 | Bug #44623: yaml

Package: univention-updater
Version: 12.0.11-3A~4.2.0.201707101705
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 6 Dirk Wiesenthal univentionstaff 2017-07-11 13:13:18 CEST
Currently, UMC does not allow to upgrade the underlying container. It only allows to upgrade the App itself.

Therefore, showing the message: '%s: Update for underlying container available' only leads to confusion.

Until the UMC App Center can upgrade containers, please remove these App updates completely.
Comment 7 Eduard Mai univentionstaff 2017-07-11 14:44:34 CEST
r81038 | Bug #44623: don't display app container updates.
r81040 | yaml

Package: univention-updater
Version: 12.0.11-4A~4.2.0.201707111440
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 8 Dirk Wiesenthal univentionstaff 2017-07-23 14:58:48 CEST
We should filter those "Container only Apps" right away. Maybe immediately after retrieving. Currently, I get an empty list:

App Center Updates
  There are App Center updates available.
  *
Comment 9 Eduard Mai univentionstaff 2017-08-10 20:17:51 CEST
Package: univention-updater
Version: 12.0.11-7A~4.2.0.201708102012
Branch: ucs_4.2-0
Scope: errata4.2-1

univention-updater (12.0.11-7):
r82045 | Bug #44623: filter container upgrades earlier
r82046 | Bug #44623: yaml
Comment 10 Dirk Wiesenthal univentionstaff 2017-08-29 13:46:33 CEST
OK, works.
Updated the YAML
Comment 11 Arvid Requate univentionstaff 2017-08-30 16:29:39 CEST
<http://errata.software-univention.de/ucs/4.2/151.html>