Bug 44659 - libav: Multiple issues (4.2)
libav: Multiple issues (4.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Arvid Requate
Felix Botner
:
Depends on: 45636
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-23 11:54 CEST by Arvid Requate
Modified: 2017-11-21 13:56 CET (History)
0 users

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 9.8 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) - CVE-2017-7862
requate: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-05-23 11:54:03 CEST
Upstream Debian package version 6:11.9-1~deb8u1 fixes:

* Multiple integer overflows have been discovered in libav 11.8 and earlier,
allowing remote attackers to cause a crash via a crafted MP3 file (CVE-2016-9821 CVE-2016-9822)
Comment 1 Arvid Requate univentionstaff 2017-11-01 17:29:27 CET
6:11.11-1~deb8u1 fixes:

* The smka_decode_frame function in libavcodec/smacker.c in FFmpeg before 2.6.5, 2.7.x before 2.7.3, and 2.8.x through 2.8.2 does not verify that the data size is consistent with the number of channels, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted Smacker data. (CVE-2015-8365)
* The decode_residual function in libavcodec in libav 9.21 allows remote attackers to cause a denial of service (buffer over-read) or obtain sensitive information from process memory via a crafted h264 video file. (CVE-2017-7208)
* FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c. (CVE-2017-7862)
* Heap-based buffer overflow in the decode_dds1 function in libavcodec/dfa.c in FFmpeg before 2.8.12, 3.0.x before 3.0.8, 3.1.x before 3.1.8, 3.2.x before 3.2.5, and 3.3.x before 3.3.1 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted file. (CVE-2017-9992)
Comment 2 Arvid Requate univentionstaff 2017-11-15 12:48:34 CET
Imported, advisory: libav.yaml
Comment 3 Felix Botner univentionstaff 2017-11-15 13:50:01 CET
we have 6:11.9-1~deb8u1 in errata 4.2-2, but the fixed version is 6:11.11-1~deb8u1
Comment 4 Arvid Requate univentionstaff 2017-11-15 17:48:14 CET
Ok Philipp fixed the tool and imported 6:11.11-1~deb8u1.
Comment 5 Felix Botner univentionstaff 2017-11-15 17:58:18 CET
OK
Comment 6 Arvid Requate univentionstaff 2017-11-21 13:56:05 CET
<http://errata.software-univention.de/ucs/4.2/223.html>