Bug 44689 - libtasn1-6: Multiple issues (4.2)
libtasn1-6: Multiple issues (4.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-24 14:20 CEST by Arvid Requate
Modified: 2017-06-28 15:33 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Security
Max CVSS v3 score:
requate: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-05-24 14:20:25 CEST
Upstream Debian package version 4.2-3+deb8u3 fixes:

* Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility. (CVE-2017-6891)
Comment 1 Philipp Hahn univentionstaff 2017-06-15 11:26:41 CEST
QA: 708# piuparts -D debian --keep-sources-list -b /var/univention/buildsystem2/pbuilder/ucs_4.2-0-errata4.2-0_amd64.tgz -d  --bindmount=/var/univention/buildsystem2/apt/ucs_4.2-0-errata4.2-0 /var/univention/buildsystem2/apt/ucs_4.2-0-errata4.2-0/amd64/libtasn1-6_4.2-3+deb8u3_amd64.deb
Comment 2 Arvid Requate univentionstaff 2017-06-22 20:17:27 CEST
* Package imported and built in errata4.2-0
* I've moved and updated the advisory to errata4.2-1
* Advisory content ok
* Package update ok
Comment 3 Janek Walkenhorst univentionstaff 2017-06-28 15:33:39 CEST
<http://errata.software-univention.de/ucs/4.2/58.html>