Bug 44730 - sudo: multiple issues (4.2)
sudo: multiple issues (4.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks: 42974
  Show dependency treegraph
 
Reported: 2017-06-01 17:47 CEST by Arvid Requate
Modified: 2017-08-16 12:44 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Security
Max CVSS v3 score: 7.8 (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
requate: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-06-01 17:47:47 CEST
Upstream Debian package version 1.8.10p3-1+deb8u4 fixes:

* Potential overwrite of arbitrary files (CVE-2017-1000367)
Comment 1 Philipp Hahn univentionstaff 2017-06-15 10:51:44 CEST
QA: piuparts -D debian --keep-sources-list -b /var/univention/buildsystem2/pbuilder/ucs_4.2-0-errata4.2-0_amd64.tgz -d  --bindmount=/var/univention/buildsystem2/apt/ucs_4.2-0-errata4.2-0 /var/univention/buildsystem2/apt/ucs_4.2-0-errata4.2-0/amd64/sudo_1.8.10p3-1+deb8u4_amd64.deb
Comment 2 Arvid Requate univentionstaff 2017-06-22 20:15:37 CEST
* Package imported and built in errata4.2-0
* I've moved and updated the advisory to errata4.2-1
* Advisory content ok
* Package update ok
Comment 3 Arvid Requate univentionstaff 2017-06-26 13:06:39 CEST
Looks like the upstream Fix was incomplete and another update will be released referencing CVE-2017-1000368.
Comment 4 Philipp Hahn univentionstaff 2017-08-10 08:28:05 CEST
(In reply to Arvid Requate from comment #3)
> Looks like the upstream Fix was incomplete and another update will be
> released referencing CVE-2017-1000368.

Tagged as "minor" for Debian-Jessie: <https://security-tracker.debian.org/tracker/CVE-2017-1000368>
Comment 5 Arvid Requate univentionstaff 2017-08-10 11:57:25 CEST
Yes, the reasoning for the rating by Debian is not very transparent. IMHO, if the tracker shows a high NVD severity rating then they should ad a note why they beg to differ. OTOH the NVD severity rating is seen as useless by Debian anyway AFAIK
Comment 6 Erik Damrose univentionstaff 2017-08-16 12:44:24 CEST
<http://errata.software-univention.de/ucs/4.2/134.html>