Bug 44814 - UTC binary in timezone info overwritten bei Europe/Berlin
UTC binary in timezone info overwritten bei Europe/Berlin
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Felix Botner
Eduard Mai
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 13:12 CEST by Nico Gulden
Modified: 2017-08-09 16:57 CEST (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.154
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Ticket number: 2017060921000241, 2017072621000172
Bug group (optional): External feedback, Troubleshooting
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2017-06-19 13:12:33 CEST
Customer feedback from Ticket#2017060921000241.

In the UCS version 4.2 the UTC binary in /usr/share/zoneinfo/ is overwritten by file /usr/share/zoneinfo/Europe/Berlin.

Received invitations in Zimbra and Kopano are scheduled two hours too early. 

Workaround: Restore the original UTC file.
Comment 1 Erik Damrose univentionstaff 2017-06-19 13:28:32 CEST
How was the setup done? DVD/Appliance/...?

On my system with Kopano installed everything seems to be correct:
# cat /etc/timezone
Europe/Berlin

# md5sum /usr/share/zoneinfo/Europe/Berlin
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/Europe/Berlin
# md5sum /usr/share/zoneinfo/UTC 
c79354b8dbee09e62bbc3fb544853283  /usr/share/zoneinfo/UTC
Comment 2 Nico Gulden univentionstaff 2017-06-20 09:05:18 CEST
(In reply to Erik Damrose from comment #1)
> How was the setup done? DVD/Appliance/...?

I requested more information from the feedback source.
Comment 3 Nico Gulden univentionstaff 2017-06-20 15:22:06 CEST
(In reply to Erik Damrose from comment #1)
> How was the setup done? DVD/Appliance/...?

Response from the user: UCS-Installation-amd64.iso
Comment 4 Erik Damrose univentionstaff 2017-06-21 10:55:05 CEST
With a fresh installation from DVD the file is not overwritten.
Comment 5 Christina Scheinig univentionstaff 2017-07-26 11:44:31 CEST
Customer reported that he installed via iso on a Proxmox virtual environment.
Comment 6 Christina Scheinig univentionstaff 2017-07-28 15:37:37 CEST
I could reproduce the issue in my test environment. Proxmox is not the problem here.
To reproduce you need to install a UCS 4.2 and Kopano-core (Kopano-WebApp).  md5sum /usr/share/zoneinfo/UTC is still correct:
c79354b8dbee09e62bbc3fb544853283  /usr/share/zoneinfo/UTC

But after installing Nextcloud via Appcenter /usr/share/zoneinfo/UTC is overwritten:
md5sum /usr/share/zoneinfo/UTC 
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/UTC
Comment 7 Stefan Gohmann univentionstaff 2017-07-28 16:29:21 CEST
Thanks, so it seems to be an App Center / Docker issue.
Comment 8 Felix Botner univentionstaff 2017-08-01 17:41:26 CEST
Problem is:

/etc/localtime is a link to /usr/share/zoneinfo/Etc/UTC in some docker apps. On the host the overlay merged dir looks like this

-> ls -al /var/lib/docker/overlay/f5f703e54212582833eba5577a838efda3d8c03864291a76e9f40a51ba3f6b7c/merged/etc/localtime 
lrwxrwxrwx 1 root root 27 Jul 19 16:41 /var/lib/docker/overlay/f5f703e54212582833eba5577a838efda3d8c03864291a76e9f40a51ba3f6b7c/merged/etc/localtime -> /usr/share/zoneinfo/Etc/UTC

-> ls -la /usr/share/zoneinfo/Etc/UTC
lrwxrwxrwx 1 root root 6 Nov 24  2016 /usr/share/zoneinfo/Etc/UTC -> ../UTC

And the AppCenter always copies /etc/localtime to the container. Unfortunately, the appcenter copies the file on the host and overwrites /usr/share/zoneinfo/Etc/UTC with /etc/localtime.

Fix: Use docker cp in the AppCenter
   docker cp [--help] CONTAINER:SRC_PATH DEST_PATH|-
   docker cp [--help] SRC_PATH|- CONTAINER:DEST_PATH
   The CONTAINER can be a running  or  stopped  container.

Repair broken systems:

-> univention-install --reinstall tzdata

on the host repairs (reinstalls) the /usr/share/zoneinfo/Etc/UTC
Comment 9 Felix Botner univentionstaff 2017-08-03 12:04:16 CEST
added cp_to_container and cp_from_container (docker cp) and replaced  _copy_files_into_ in docker_base

QA:

previously /usr/share/zoneinfo/UTC got overwritten on the host during the owncloud/nextcloud installation. So at least check

 md5sum /usr/share/zoneinfo/UTC

before and after the installation on the host.
Comment 10 Eduard Mai univentionstaff 2017-08-03 17:54:40 CEST
Works as expected.
Comment 11 Arvid Requate univentionstaff 2017-08-09 16:57:22 CEST
<http://errata.software-univention.de/ucs/4.2/127.html>