Bug 44824 - updater/maintenance_information: AttributeError / ScannerError / ReaderError
updater/maintenance_information: AttributeError / ScannerError / ReaderError
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Software update
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Jannik Ahlers
Florian Best
:
: 45078 45519 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 12:00 CEST by Florian Best
Modified: 2017-11-29 12:04 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017111521000765, 2017112221000617, 2017061721000084, 2017092921000556, 2017072221000171, 2017101821000011, 2017101921000625, 2017110821000975
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
get more information (deleted)
2017-06-20 12:20 CEST, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-06-20 12:00:40 CEST
4.2-0 errata0 (Lesum)

Execution of command 'updater/maintenance_information' has failed:

Traceback (most recent call last):
line 249, in execute
"/usr/lib/pymodules/python2.7/univention/management/console/base.py",
   File
     function.__func__(self, request, *args, **kwargs)
line 318, in _response
"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
   File
     result = _multi_response(self, request)
line 192, in _response
"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
   File
     return function(self, request)
line 440, in _response
"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
   File
     return list(function(self, iterator, *nones))
line 286, in _fake_func
"/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
   File
     yield function(self, *args)
line 226, in query_maintenance_information
"/usr/lib/pymodules/python2.7/univention/management/console/modules/updater/__init__.py",
   File
     _maintained_status = status.get('maintained')
AttributeError: 'str' object has no attribute 'get'
Comment 1 Florian Best univentionstaff 2017-06-20 12:20:24 CEST
Created attachment 8938 [details]
get more information
Comment 2 Florian Best univentionstaff 2017-11-02 21:59:03 CET
*** Bug 45519 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2017-11-02 21:59:09 CET
*** Bug 45078 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2017-11-08 11:59:56 CET
OK: the changes look good. Please create a YAML file, merge the changes into the 4.2-2 branch and build the package.
Comment 5 Florian Best univentionstaff 2017-11-08 12:00:10 CET
The content of attachment 8938 [details] has been deleted for the following reason:

obsolete
Comment 6 Jannik Ahlers univentionstaff 2017-11-08 16:25:14 CET
Improved error handling when querying maintenance status information.
Comment 7 Florian Best univentionstaff 2017-11-09 12:49:29 CET
OK: Very nice, every of the errors are suppressed and don't cause any message on the UCS system.
OK: YAML
Comment 8 Arvid Requate univentionstaff 2017-11-09 16:56:49 CET
<http://errata.software-univention.de/ucs/4.2/219.html>
Comment 9 Jannik Ahlers univentionstaff 2017-11-22 16:16:22 CET
*** Bug 44080 has been marked as a duplicate of this bug. ***
Comment 11 Johannes Keiser univentionstaff 2017-11-29 12:04:02 CET
Version: 4.2-1 errata118 (Lesum)