Bug 44842 - Remove QEMU check in preup.sh
Remove QEMU check in preup.sh
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - univention-updater
UCS 4.2
All Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Philipp Hahn
Stefan Gohmann
http://sdb.univention.de/solution_id_...
:
Depends on: 44083
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 16:57 CEST by Philipp Hahn
Modified: 2017-08-30 16:29 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
hahn: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2017-06-22 16:57:12 CEST
The preup.sh script still contains the check for old running/suspended QEMU VMs.
It should be removed.
+++ This bug was initially created as a clone of Bug #44083 +++
+++ This bug was initially created as a clone of Bug #38877 +++
Comment 1 Philipp Hahn univentionstaff 2017-06-22 16:59:22 CEST
sed -i '/^check_qemu /,/^check_qemu$/d' script/preup.sh
Comment 2 Philipp Hahn univentionstaff 2017-06-23 08:23:02 CEST
r80434 | Bug #44842 up: Remove QEMU check from preup.sh

Package: univention-updater
Version: 12.0.11-2A~4.2.0.201706230818
Branch: ucs_4.2-0
Scope: errata4.2-1

r80437 | Bug #44821, Bug #44842 updater.yaml
r80436 | Bug #44821, Bug #44842 updater.yaml
Comment 3 Stefan Gohmann univentionstaff 2017-07-25 06:26:13 CEST
Code review: OK

Tests: OK

YAML: OK
Comment 4 Arvid Requate univentionstaff 2017-08-30 16:29:42 CEST
<http://errata.software-univention.de/ucs/4.2/151.html>