Bug 44885 - Regression: Re-joining UCS@school Slave PDCs skips fix for Bug 33881
Regression: Re-joining UCS@school Slave PDCs skips fix for Bug 33881
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Felix Botner
Arvid Requate
:
Depends on: 39251
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 22:18 CEST by Arvid Requate
Modified: 2017-11-09 16:56 CET (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.143
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
requate: Patch_Available+


Attachments
fix_regression_of_bug39251.patch (525 bytes, patch)
2017-06-28 22:18 CEST, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-06-28 22:18:00 CEST
Created attachment 8983 [details]
fix_regression_of_bug39251.patch

Code review suggests that the fix for Bug #39251 causes a regression for UCS@school Samba/AD Slave PDCs:

Since that fix, rejoining a UCS@school Samba/AD Slave PDC does not enter the samba4/provision/secondary branch of the univention-samba4 joinscript any longer, where some special steps are performed, like the fix for Bug #33881 and other things. Instead the samba4/provision/primary branch is run during re-join of all systems running an S4-Connector.

The attached patch may be suitable to fix this regression.
Comment 1 Felix Botner univentionstaff 2017-11-07 16:15:22 CET
as discussed, reorganized the samba4 join script

IF samba4/provision/primary is true
 OR not connectors
   OR "i am the connector"
     THEN samba provisioning
         within this block if samba4/provision/secondary is true
         (set in school slave meta packages) we use some special
         options for ucs@school
ELSE
 samba join

my tests, see Bug #45596

univention-samba4 6.0.10-41A~4.2.0.201711061824
Comment 2 Arvid Requate univentionstaff 2017-11-08 19:24:45 CET
Ok.
Comment 3 Arvid Requate univentionstaff 2017-11-09 16:56:50 CET
<http://errata.software-univention.de/ucs/4.2/218.html>