Bug 44895 - Initial login on Windows 10 leads to error message
Initial login on Windows 10 leads to error message
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.1
Other Windows 10
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Felix Botner
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 13:26 CEST by Michel Smidt
Modified: 2017-12-04 13:05 CET (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.171
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Initial Windows 10 login (116.05 KB, image/png)
2017-06-29 13:26 CEST, Michel Smidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Smidt univentionstaff 2017-06-29 13:26:01 CEST
Created attachment 8986 [details]
Initial Windows 10 login

Reproducible.
Initial login from a student "schueler02".
Error message as seen in the screenshot.
If the user already was logged in on a windows 7 machine it works.
UCS seems to create only "default.V2-5" by default:
default  default.V2  default.V3  default.V4  default.V5  Vista  Vista.V2  Win2k  Win2K3  Win95  WinNT  WinXP
Not the necessary "default.V6" directory.
The Windows 10 client seems to create the dir:
schueler/schueler02/windows-profiles# getfacl default.V[56]":

# file: default.V5
# owner: schueler02
# group: Domain\040Users\040e915
user::rwx
group::---
other::---

# file: default.V6
# owner: schueler02
# group: Domain\040Users\040e915
user::rwx
user:schueler02:rwx
user:5035:rwx
group::---
group:System:rwx
group:Domain\040Users\040e915:---
mask::rwx
other::---
default:user::rwx
default:user:schueler02:rwx
default:user:5035:rwx
default:group::---
default:group:System:rwx
default:group:Domain\040Users\040e915:---
default:mask::rwx
default:other::---
Comment 1 Michel Smidt univentionstaff 2017-07-13 10:29:15 CEST
Customer re-asked for it.
Comment 2 Stefan Gohmann univentionstaff 2017-07-21 07:57:33 CEST
Felix, please have a look.
Comment 3 Felix Botner univentionstaff 2017-08-09 12:49:30 CEST
I can not reproduce this with win10 1703. Windows always creates the default.V6 directory if missing (without any complains during login).

Nevertheless we add default to the skel as this is a trivial change.
Comment 4 Felix Botner univentionstaff 2017-08-09 14:15:09 CEST
errata4.2-1 univention-samba4 r81922
Comment 5 Arvid Requate univentionstaff 2017-08-28 19:19:05 CEST
Ok.
Comment 6 Arvid Requate univentionstaff 2017-09-13 16:35:07 CEST
<http://errata.software-univention.de/ucs/4.2/164.html>
Comment 7 Michel Smidt univentionstaff 2017-12-04 13:05:11 CET
Customer confirmed that it is working now.