Bug 44905 - Disabling UMC module autosearch has no consequence to sizelimit
Disabling UMC module autosearch has no consequence to sizelimit
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Florian Best
Alexander Kläser
:
Depends on:
Blocks: 45334
  Show dependency treegraph
 
Reported: 2017-06-30 09:09 CEST by Christina Scheinig
Modified: 2017-09-20 15:04 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.286
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Ticket number: 2017062821000911, 2017081421000175, 2017082421000291
Bug group (optional): Workaround is available
Max CVSS v3 score:


Attachments
patch (827 bytes, patch)
2017-09-01 11:06 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christina Scheinig univentionstaff 2017-06-30 09:09:31 CEST
The customer upgraded his school environment to 4.2-1. Entering e.g the UMC user module he has got the following error message:

"The query you have entered yields too many matching entries. Please narrow down your search by specifying more query parameters. The current size limit of 2000 can be configured with the UCR variable directory/manager/web/sizelimit."

This is weird because the ucr variable directory/manager/web/modules/autosearch
was already set to 0 before the upgrade.

The message disappeared when he set directory/manager/web/sizelimit to 100.000.

I think this should not be necessary, if the autosearch is disabled.
Comment 1 Christina Scheinig univentionstaff 2017-08-24 14:46:12 CEST
Happened again, displaying shares this time.
directory/manager/web/modules/autosearch was set to 0 and 
directory/manager/web/sizelimit was still 2000 as default
Comment 2 Stefan Gohmann univentionstaff 2017-08-25 10:54:05 CEST
It looks like a regression which has been added in UCS 4.2. If I remember correctly, a input search value was shown in these cases.
Comment 3 Florian Best univentionstaff 2017-08-31 17:09:16 CEST
Bug #26556 implemented a feature for this which seems to be broken.
Comment 4 Florian Best univentionstaff 2017-09-01 11:06:55 CEST
Created attachment 9164 [details]
patch

This is a regression introduces in Bug #42533 svn r78923.
Attached is a patch.

patch -p6 -d /usr/share/pyshared/univention/management/console/modules/udm/ < ~/44905.patch
Comment 5 Florian Best univentionstaff 2017-09-06 10:21:13 CEST
univention-management-console-module-udm (7.0.10-19):
r82704 | Bug #44905: fix searchable combobox if sizelimit is reached

univention-management-console-module-udm.yaml:
r82706 | YAML Bug #44905
Comment 6 Alexander Kläser univentionstaff 2017-09-18 12:03:43 CEST
Works as expected. YAML file is OK.

→ VERIFIED
Comment 7 Erik Damrose univentionstaff 2017-09-20 15:04:02 CEST
<http://errata.software-univention.de/ucs/4.2/180.html>