Bug 44948 - Mail delivery for cyrus shared folders is broken
Mail delivery for cyrus shared folders is broken
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Mail
UCS 4.2
Other Linux
: P5 enhancement (vote)
: UCS 4.2-1-errata
Assigned To: Sönke Schwardt-Krummrich
Erik Damrose
:
Depends on: 42249
Blocks: 38672 44705 44949
  Show dependency treegraph
 
Reported: 2017-07-06 16:02 CEST by Sönke Schwardt-Krummrich
Modified: 2017-07-12 16:49 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.343
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?: Yes
Ticket number: 2017070421000383
Bug group (optional): External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2017-07-06 16:02:56 CEST
Unfortunately due to bug 42249 there is a regression regarding mail delivery to shared folder in Cyrus.

The mailPrimaryAddress of the shared folder is not rewritten within postfix to the cyrus LMTP address.
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2017-07-06 17:37:10 CEST
Cause of the regression:
Address rewriting via virtual_mailbox_maps is only performed if the delivery
program 'virtual' is in use. Other delivery programs will no rewrite the
addresses. In bug 42249 the address rewriting was splitted into
virtual_alias_maps and virtual_mailbox_maps. While the latter one was (mostly) a no-op rewriting from mailPrimaryAddress to mailPrimaryAddress.

Unfortunately the rewriting for cyrus shared folders from mailPrimaryAddress to 
univentionMailSharedFolderDeliveryAddress was completely moved to virtual_mailbox_maps and was therefore no longer performed.

univention-mail-postfix (11.0.1-15):
r80933 | Bug #44948: fixed regression in delivery of mails to cyrus shared folders

univention-mail-postfix.yaml:
r80935 | Bug #44948: added advisory
Comment 2 Erik Damrose univentionstaff 2017-07-10 13:35:57 CEST
With u-mail-postfix-ox version 11.0.1-14A~4.2.0.201706191335: to=<myshared@ucs.local>

OK: With u-mail-postfix-ox 11.0.1-15A~4.2.0.201707061650: to=<univentioninternalpostuser+shared/myshared@ucs.local

OK~: yaml, fixed in r80998
Verified
Comment 3 Janek Walkenhorst univentionstaff 2017-07-12 16:49:30 CEST
<http://errata.software-univention.de/ucs/4.2/89.html>