Bug 45100 - Whitespaces are not stripped from user entry yielding in stopped DNS service
Whitespaces are not stripped from user entry yielding in stopped DNS service
Status: RESOLVED MOVED
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UCS 5.0
Other Linux
: P5 normal (vote)
: UCS 5.0-5-errata
Assigned To: Marius Meschter
Philipp Hahn
https://git.knut.univention.de/univen...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 16:37 CEST by Nico Gulden
Modified: 2023-10-17 15:22 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.240
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number: 2017072021000272, 2023100521000381
Bug group (optional): bitesize, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2017-07-28 16:37:58 CEST
A user reported at Ticket#2017072021000272

Creating a DNS entry with the setting `Forward Lookup Zone` does check for included whitespaces. Appending a white space at the end puts it into the configuration of the nameserver and results in a nameserver going offline.

Error occurred with UCS 4.2-0 errata95

The syslog provides the following error messages:

Jul 20 00:06:56 sr-master-01 named[4026]: zone blackboardXXXX.XXXX.de\032/NONE: has 0 SOA records
Jul 20 00:06:56 sr-master-01 named[4026]: zone blackboardXXXX.XXXX.de\032/NONE: has no NS records
Jul 20 00:06:56 sr-master-01 named[4026]: samba_dlz: Failed to configure zone 'blackboardXXXX.XXXX.de '
Jul 20 00:06:56 sr-master-01 named[4026]: loading configuration: bad zone
Jul 20 00:06:56 sr-master-01 named[4026]: exiting (due to fatal error)
Comment 1 Florian Best univentionstaff 2017-10-12 19:52:24 CEST
A not runnning DNS service is a 7-crash.
Comment 3 Wolfgang Bayrhof univentionstaff 2023-10-12 14:13:03 CEST
Another customer reported something similar with UCS 5.0-5 errata813.

Create a Forward Zone with an included space character is possible with UMC. This resulted in a stopped bind service.

snip from syslog (forward zone "Space Zone" on a test machine):

Oct 12 13:56:18 mf2primary named[13978]: zone Space\032Zone/NONE: has 0 SOA records
Oct 12 13:56:18 mf2primary named[13978]: zone Space\032Zone/NONE: has no NS records
Oct 12 13:56:18 mf2primary named[13978]: samba_dlz: Failed to configure zone 'Space Zone'
Oct 12 13:56:18 mf2primary named[13978]: loading configuration: bad zone
Oct 12 13:56:18 mf2primary named[13978]: exiting (due to fatal error)

Bug was reproducible with 5.0-5 errata830.
Comment 4 Dirk Schnick 2023-10-12 17:04:08 CEST
We were in the situation that on a replica the DNS was down and not willing to start. So without DNS no replication -> the correction (deleting that zone spaces in the name) would not arrive on the replica.

We switched to dns/backend=ldap and bind was willing to start again. We switched back to samba4 as dns/backend after the replication of the zone had arrived.

Perhaps it helps others.