Bug 45408 - Limit number of backups in /var/univention-backup
Limit number of backups in /var/univention-backup
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Felix Botner
Stefan Gohmann
:
: 45727 (view as bug list)
Depends on: 38554
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-18 10:58 CEST by Michael Grandjean
Modified: 2017-11-17 11:05 CET (History)
11 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.057
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2017-09-18 10:58:30 CEST
The cronjob that runs the cleanup is too verbose and spammy. It generates a cronmail even on success, which is quite annoying.

I guess this line here:

> find "$backup_dir" -type f -mtime "+$max_age" -regex "$pattern" -delete

should become something like:

> find "$backup_dir" -type f -mtime "+$max_age" -regex "$pattern" -delete > /dev/null

https://git.knut.univention.de/univention/ucs/blob/4.2-2/base/univention-lib/shell/backup.sh#L52)



+++ This bug was initially created as a clone of Bug #38554 +++

It would be nice to be able to limit the max amount of days for the nightly backup scripts - for example with the help of UCR.
Otherwise you have tons of unqiue backup variants underneath /var/univention-backup for the last 100xxx days.
Comment 1 Felix Botner univentionstaff 2017-09-28 13:50:11 CEST
univention-lib 9801a82e562793496a2fe7a0f6791fd80e6c1d09

Package: univention-lib
Version: 6.0.9-17A~4.2.0.201709281346
Branch: ucs_4.2-0
Scope: errata4.2-2
Comment 2 Stefan Gohmann univentionstaff 2017-10-02 16:15:48 CEST
Code review: OK

YAML: OK

Tests: OK
Comment 3 Arvid Requate univentionstaff 2017-10-10 15:38:49 CEST
<http://errata.software-univention.de/ucs/4.2/192.html>
Comment 4 Michel Smidt univentionstaff 2017-11-17 11:05:36 CET
*** Bug 45727 has been marked as a duplicate of this bug. ***