Bug 45424 - IE11 redirects to ucs-sso even if ucs-sso is not resolvable via DNS
IE11 redirects to ucs-sso even if ucs-sso is not resolvable via DNS
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: SAML
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Johannes Keiser
Florian Best
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-20 12:37 CEST by Sönke Schwardt-Krummrich
Modified: 2018-01-29 17:14 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.286
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2017072621000191, 2017102421000795
Bug group (optional): Browser compatibility, Error handling, External feedback, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2017-09-20 12:37:02 CEST
Due to certificate issues, a customer "disabled" SSO by removing the DNS entry for "ucs-sso". If the UMC entry on the UCS portal is select, most browsers jump directly to login prompt of UMC.
But IE11 still tries to redirect to "ucs-sso.$DOMAIN" which results in an error message.
Comment 1 Florian Best univentionstaff 2017-09-21 16:16:15 CEST
As discussed, please have a look if it is reproducible and what's the real problem.
Comment 2 Johannes Keiser univentionstaff 2017-10-05 16:49:18 CEST
I could not reproduce this issue; I tested with the latest IE11 versions on Browserstack (win 7,8.1,10) and a VM with win7 (IE11 v. 11.0.9600).

On which windows version was IE11 used?
Comment 3 Florian Best univentionstaff 2017-11-30 17:06:06 CET
I think this is fixed in UCS 4.2-3. I saw some javascript tracebacks that localStorage is not defined. That code has been removed. Probably UMC works properly again with IE11. Please REOPEN this bug if the issue occurs again.
Comment 4 Johannes Keiser univentionstaff 2017-12-13 17:54:09 CET
univention-management-console (9.0.80-86):

38c5dc3 Bug #45424: fix iframe error with IE 11
84cfcb2 Bug #45424: debian changelog entry
d034842 Bug #45424: Merge branch 'jkeiser/bug_45424__IE_11_redirects_to_ucs_sso' into 4.2-3
f5f0182 Bug #45424: YAML
c9fdf9c Bug #45424: YAML - add version
Comment 5 Florian Best univentionstaff 2017-12-13 18:04:50 CET
Please merge the changes to UCS 4.3-0.
Comment 6 Johannes Keiser univentionstaff 2017-12-13 18:56:36 CET
(In reply to Florian Best from comment #5)
> Please merge the changes to UCS 4.3-0.

08394cd Bug #45424: fix iframe error with IE 11
ce280c1 Bug #45424: debian changelog entry
Comment 7 Florian Best univentionstaff 2018-01-22 19:05:12 CET
OK: works with all browsers
OK: YAML (adjusted the description in 2fb1573f06c7).
Comment 8 Arvid Requate univentionstaff 2018-01-29 17:14:02 CET
<http://errata.software-univention.de/ucs/4.2/272.html>