Bug 45438 - Get more information about "INVALID_CREDENTIALS" exception
Get more information about "INVALID_CREDENTIALS" exception
Status: CLOSED DUPLICATE of bug 44382
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 major (vote)
: UCS 4.2-2-errata
Assigned To: Florian Best
Stefan Gohmann
:
Depends on: 44382 44912
Blocks: 44621
  Show dependency treegraph
 
Reported: 2017-09-22 14:06 CEST by Florian Best
Modified: 2017-10-02 15:59 CEST (History)
7 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-09-22 14:06:24 CEST
We should cover the exception so that it includes more useful information for debugging.

+++ This bug was initially created as a clone of Bug #44382 +++

Version: 4.2-0 errata0 (Lesum)

Traceback(2f3ef65aec439efd21b19f22fa444fab):
Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 178, in _recv
    self.handle(msg)
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 178, in _recv
    self.handle(msg)
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 178, in _recv
    self.handle(msg)
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 178, in _recv
    self.handle(msg)
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 178, in _recv
    self.handle(msg)
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 290, in handle
    self.__handler.init()
  File "%PY2.7%/univention/management/console/modules/udm/__init__.py", line 157, in init
    self.settings = UDM_Settings()
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 886, in __init__
    self.read()
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 889, in read
    self._read_directories()
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 88, in _decorated
    return method(*args, **kwargs)
  File "%PY2.7%/univention/management/console/ldap.py", line 140, in _decorated
    kwargs[loarg], kwargs[poarg] = lo, po = getter()
  File "%PY2.7%/univention/management/console/ldap.py", line 130, in getter
    conn = connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 53, in connection
    bind(lo)
  File "%PY2.7%/univention/management/console/modules/udm/__init__.py", line 173, in bind_user_connection
    super(Instance, self).bind_user_connection(lo)
  File "%PY2.7%/univention/management/console/base.py", line 353, in bind_user_connection
    lo.lo.bind(self._user_dn, self._password)
  File "%PY2.7%/univention/uldap.py", line 165, in bind
    self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in simple_bind_s
    res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in _apply_method_s
    return func(self,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in simple_bind_s
    resp_type, resp_data, resp_msgid, resp_ctrls = self.result3(msgid,all=1,timeout=self.timeout)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in result3
    resp_ctrl_classes=resp_ctrl_classes
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in result4
    ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in _ldap_call
    result = func(*args,**kwargs)
INVALID_CREDENTIALS: The initialization of the module failed
Comment 1 Florian Best univentionstaff 2017-09-22 15:43:22 CEST
Error are now showing more information:
* authentication type
* if it is a SAML message (determined by a password longer than 20 chars) the length of the saml message is printed
* the length of the DN (might be 0)

univention-management-console.yaml:
6aa6015b5941 | YAML Bug #45438

Accidently commited with wrong bug number:

univention-management-console (9.0.80-72):
0f023244c2de | Merge branch 'fbest/44382-invalid-credentials' into 4.2-2
a53597a4173c | Bug #44382: be more verbose about LDAP authentication failures
Comment 2 Eduard Mai univentionstaff 2017-09-22 18:12:04 CEST
Due to changes made via #44670 the intended traceback is suppressed at least for UDM modules. Them change might be insufficient as the intended information is not shown in this case.
Comment 3 Florian Best univentionstaff 2017-09-27 11:24:43 CEST

*** This bug has been marked as a duplicate of bug 44382 ***
Comment 4 Stefan Gohmann univentionstaff 2017-10-02 15:56:41 CEST
(In reply to Florian Best from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 44382 ***

OK
Comment 5 Stefan Gohmann univentionstaff 2017-10-02 15:59:39 CEST
(In reply to Stefan Gohmann from comment #4)
> (In reply to Florian Best from comment #3)
> > 
> > *** This bug has been marked as a duplicate of bug 44382 ***
> 
> OK

Nothing to release