Bug 45454 - Nagios check UNIVENTION_SMBD fails / guest login via smbclient not possible
Nagios check UNIVENTION_SMBD fails / guest login via smbclient not possible
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Felix Botner
Stefan Gohmann
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-26 11:26 CEST by Sönke Schwardt-Krummrich
Modified: 2017-10-10 15:38 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Ticket number: 2017092621000347, 2017092121000454
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2017-09-26 11:26:26 CEST
A customer reported that the nagios check UNIVENTION_SMBD fails since erratum 165 for UCS 4.2-1 has been installed. It looks like there are problem, when smbclient tries to log in with the user "guest".

The nagios check returns
"CRITICAL: smbclient failed: session setup failed: NT_STATUS_LOGON_FAILURE"
Comment 1 Stefan Gohmann univentionstaff 2017-09-26 11:29:26 CEST
See also Bug #45453.
Comment 2 Felix Botner univentionstaff 2017-09-27 18:29:18 CEST
ok, smbclient -U guest -N -L hostname no longer works (samba regression?)
but smbclient  -N -L hostname

i replaced the command in nagios plugin check_univention_smbd (removed the -U paramter), but i did not change the nagios service/config, they still know/set/use the -U parameter (which is no longer used by the plugin)

this is not beautiful, but i wanted to change as few tings as possible and maybe the samba behavior changes again in the future ...


yaml 019c6c8969fffd7df5d8a7f0b519f763daf79145, 802913d567caa6a87ac812c1738fc4d961e9daf8
univention-nagios ffd76f0d0a0c3a0c8116ed23c99bf698b6b12e1d, 857e06faabf32d2087062f2b2d10755d2c312e18
Comment 3 Stefan Gohmann univentionstaff 2017-10-02 16:32:52 CEST
Code review: OK

Tests: OK, works again

YAML: OK
Comment 4 Arvid Requate univentionstaff 2017-10-10 15:38:51 CEST
<http://errata.software-univention.de/ucs/4.2/193.html>