Bug 45514 - The ssh-login to ${DCACCOUNT}@${DCNAME} failed with \"${ssh_out}\". Please make sure the account ${DCACCOUNT} exists and is a member of the Domain Admins group!
The ssh-login to ${DCACCOUNT}@${DCNAME} failed with \"${ssh_out}\". Please ma...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Join (univention-join)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Felix Botner
Erik Damrose
:
: 45520 (view as bug list)
Depends on: 42425
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-12 20:07 CEST by Florian Best
Modified: 2018-06-06 16:16 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2018032021001053, 2017103021000541, 2017091221000668, 2017101021000301, 2017092621000589, 2017092321000281
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-10-12 20:07:02 CEST
The signature changed into:

Version: 4.2-2 errata189 (Lesum)

Remark: Standard Installation,....Option Member Server in AD.

Traceback(d41d8cd98f00b204e9800998ecf8427e):
Domain setup (this might take a while): The ssh-login to Administrator@**** failed with "ssh: connect to host ucs-server.homelab.loc port 22: Connection refused
". Please make sure the account Administrator exists and is a member of the Domain Admins group!

+++ This bug was initially created as a clone of Bug #42425 +++

Version: 4.1-3 errata268 (Vahr)

We received the following feedback:
Domäneneinrichtung (Dies kann einige Zeit dauern): ssh-login for Administrator@ac001c01.deac.****** failed. Maybe you entered a wrong password.

We should check this prior to starting the setup wizard.
Comment 1 Florian Best univentionstaff 2017-10-12 21:04:16 CEST
Version: 4.2-2 errata157 (Lesum)

Remark: it only worked once, never aftewards (due  to necesserry reinstallation). Although cleaneing up the ADS (based on Samba4)
Comment 2 Florian Best univentionstaff 2017-10-12 21:11:48 CEST
Version: 4.2-2 errata184 (Lesum)
Comment 3 Florian Best univentionstaff 2017-10-12 21:32:47 CEST
Version: 4.2-2 errata159 (Lesum)
Comment 4 Florian Best univentionstaff 2017-11-10 15:31:24 CET
Reported again, 4.2-2 errata204 (Lesum)
Comment 5 Johannes Keiser univentionstaff 2018-04-13 12:37:57 CEST
Reported again: Version: 4.3-0 errata0 (Neustadt)

Domain setup (this might take a while): The ssh-login to Administrator@intra.yaka.fr.cr failed with "bash: /home/Administrator/.bashrc: Permission non accordée ls: impossible
d'ouvrir le répertoire '.': Permission non accordée ". Please make sure the account Administrator exists and is a member of the Domain Admins group!


Role: domaincontroller_backup
Comment 6 Felix Botner univentionstaff 2018-05-23 17:29:54 CEST
*** Bug 45520 has been marked as a duplicate of this bug. ***
Comment 7 Felix Botner univentionstaff 2018-05-23 17:39:38 CEST
idea:

add a link to a knowledge base article about join problems to the standard join fail message

kbd: https://help.univention.com/t/8842
univention-join b97c09b6dd7acfe368d7de3171f2d2d952efd089
yaml: 32c10260090849ecb771d43c66ae0c39f08f2062

qa:

 * Is that even helpful?
 * article: wording, spelling, informations
 * is the fail message ok (command line, UMC, setup?)
Comment 8 Erik Damrose univentionstaff 2018-06-04 17:19:32 CEST
(In reply to Felix Botner from comment #7)
>  * Is that even helpful?

We will see if the feedback tickets with error messages regarding these problems will go down in volume. I think its a good start. We also added checks to system setup a while ago to catch these errors early.

>  * article: wording, spelling, informations

I made some small adjustments to the article.

>  * is the fail message ok (command line, UMC, setup?)

Please adjust the code so that the hint to the SDB article is on a separate line from the error message. Also, please comply with the line length of the surrounding statements. -> reopen
Comment 9 Felix Botner univentionstaff 2018-06-04 17:36:26 CEST
(In reply to Erik Damrose from comment #8)
> 
> >  * is the fail message ok (command line, UMC, setup?)
> 
> Please adjust the code so that the hint to the SDB article is on a separate
> line from the error message. Also, please comply with the line length of the
> surrounding statements. -> reopen

the umc setup looks for the "* Message:" line and prints only this line in the dialog, so at the moment we can only have a on liner error message
Comment 10 Erik Damrose univentionstaff 2018-06-04 17:38:42 CEST
Thanks for the clarification. I agree that the current solution is okay for now
OK: univention-join
OK: yaml
Verified
Comment 11 Erik Damrose univentionstaff 2018-06-06 16:16:21 CEST
<http://errata.software-univention.de/ucs/4.3/95.html>