Bug 45533 - appcenter/docker/progress: IOError: [Errno 28] No space left on device
appcenter/docker/progress: IOError: [Errno 28] No space left on device
Status: RESOLVED DUPLICATE of bug 45529
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-13 12:29 CEST by Florian Best
Modified: 2017-11-14 16:33 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017091421000208, 2017101921000072
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-10-13 12:29:58 CEST
Version: 4.2-1 errata159 (Lesum)

Die Ausführung des Kommandos appcenter/docker/progress ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 249, in execute
    function.__func__(self, request, *args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 440, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 286, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/mixins.py", line 149, in progress
    ret = progress_obj.poll()
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 309, in _thread
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 440, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 286, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 417, in invoke_docker
    result['success'] = action.call(app=app, username=self.username, password=self.password, **kwargs)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 239, in call
    return obj.call_with_namespace(namespace)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 245, in call_with_namespace
    result = self.main(namespace)
  File "%PY2.7%/univention/appcenter/actions/upgrade.py", line 75, in main
    return self.do_it(args)
  File "%PY2.7%/univention/appcenter/actions/install_base.py", line 118, in do_it
    if not can_continue or not self._call_prescript(app, args):
  File "%PY2.7%/univention/appcenter/actions/upgrade.py", line 92, in _call_prescript
    return super(Upgrade, self)._call_prescript(app, args, old_version=self.old_app.version)
  File "%PY2.7%/univention/appcenter/actions/install_base.py", line 213, in _call_prescript
    with self._get_password_file(args) as pwdfile:
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "%PY2.7%/univention/appcenter/actions/credentials.py", line 130, in _get_password_file
    password_file.flush()
IOError: [Errno 28] Auf dem Gerät ist kein Speicherplatz mehr verfügbar
Comment 1 Florian Best univentionstaff 2017-10-23 16:53:50 CEST
Reported again, 4.1-4 errata443 (Vahr)
Comment 2 Dirk Wiesenthal univentionstaff 2017-11-14 16:33:55 CET

*** This bug has been marked as a duplicate of bug 45529 ***