Bug 45548 - Dudle: Version 1.1.0-1 can be upgraded to 1.1.0-1
Dudle: Version 1.1.0-1 can be upgraded to 1.1.0-1
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other other
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-16 16:02 CEST by Michael Grandjean
Modified: 2018-05-04 11:45 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.091
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Screenshot of univention-upgrade (7.84 KB, image/png)
2017-10-16 16:02 CEST, Michael Grandjean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2017-10-16 16:02:48 CEST
Created attachment 9250 [details]
Screenshot of univention-upgrade

Just came across this message while using "univention-upgrade" on a UCS 4.2-2 errata 189:

"Dudle: Version 1.1.0-1 can be upgraded to 1.1.0-1"

Not sure if this does any harm, but the version comparison is obviously broken.
Comment 1 Dirk Wiesenthal univentionstaff 2017-10-16 16:44:01 CEST
Fixed in
  univention-updater 12.0.11-10A~4.2.0.201710161640

univention-upgrade still used the old AppManager class. See Bug#44542.
Comment 2 Felix Botner univentionstaff 2017-10-26 18:20:02 CEST
I could not reproduce this, nevertheless the code looks good.


OK - univention-update
OK - YAML
Comment 3 Arvid Requate univentionstaff 2017-11-01 13:49:26 CET
<http://errata.software-univention.de/ucs/4.2/209.html>