Bug 45581 - inconsistent behavior of umc/users email field
inconsistent behavior of umc/users email field
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Users
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Dirk Wiesenthal
Johannes Keiser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-24 11:03 CEST by Daniel Tröder
Modified: 2018-04-18 13:51 CEST (History)
8 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 4: Will affect most installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.343
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Waiting Support: Yes
Ticket number: 2017102421000179, 2017092521000358, 2018011021000577
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tröder univentionstaff 2017-10-24 11:03:30 CEST
When a user without an entry in the "email" (contacts) field has a mailPrimaryAddress, the UMC shows the mailPrimaryAddress in the "email" field. 
However when saving the user the email field is not saved.
It is only saved, when adding a 2nd address to "email". Then both addresses will be saved. When removing the 2nd address, the first remains in LDAP, even if it is still the same as the mailPrimaryAddress.

Either
* the contacts field should not be shown as filled when if it's not, or
* it should be saved to LDAP
Comment 1 Florian Best univentionstaff 2017-10-26 13:08:52 CEST
Does it cause any problem currently?
Comment 2 Daniel Tröder univentionstaff 2017-11-08 11:14:29 CET
(In reply to Florian Best from comment #1)
> Does it cause any problem currently?
Yes: a customer is affected.
Comment 3 Stefan Gohmann univentionstaff 2017-11-08 11:38:00 CET
(In reply to Daniel Tröder from comment #2)
> (In reply to Florian Best from comment #1)
> > Does it cause any problem currently?
> Yes: a customer is affected.

Yes, UMC shows an mail address for the user but it isn't set. Thus, mail clients didn't find the contact information.
Comment 4 Christina Scheinig univentionstaff 2017-11-08 12:10:54 CET
The customer needs a patch urgently
Comment 5 Florian Best univentionstaff 2017-11-08 12:15:34 CET
This is kind of a regression from Bug #41053 because the e-mail property has a default value of ['<mailPrimaryAddress>'] which is since then also evaluated when modifying the object.
Comment 6 Nico Stöckigt univentionstaff 2018-03-02 14:11:58 CET
This bug is worth another customer ticket.


In detail:

On a fresh UCS 4.2-3 standalone mailserver one creates a new user without any e-mail attributes and adds the mailPrimaryAddress afterwards. What happened is the mailPrimaryAddress is shown in the contact tab without writing the value into the 'mail' attribute. This behavior is absolutely inconsistent.
Comment 7 Stefan Gohmann univentionstaff 2018-03-15 06:32:49 CET
Move to 4.3-0-errata. If a UCS 4.2 backport is needed, please clone this issue.
Comment 8 Dirk Wiesenthal univentionstaff 2018-04-06 11:33:51 CEST
I have removed line
  default=['<mailPrimaryAddress>']
in the e-mail field definition.
Comment 9 Johannes Keiser univentionstaff 2018-04-17 18:17:28 CEST
OK e-mail does no longer use mailPimaryAddress as default
-> verified
Comment 10 Arvid Requate univentionstaff 2018-04-18 13:51:56 CEST
<http://errata.software-univention.de/ucs/4.3/13.html>