Bug 45670 - Check available space before backing up docker app data
Check available space before backing up docker app data
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other All
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Felix Botner
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-08 15:48 CET by Michael Grandjean
Modified: 2018-04-18 13:51 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.240
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2017-11-08 15:48:16 CET
Expected behaviour:

Before performing a backup of the Docker App data during the Docker App upgrade, the available disk space is checked and the upgrade aborts if not enough space is left on the device.


Observed behaviour:

> 07.11.17 14:32:35.770  MODULE      ( PROCESS ) : Going to upgrade Nextcloud (12.0.3-0)
> [...]
> 07.11.17 14:35:01.609  MODULE      ( PROCESS ) : Saving data from old container (nextcloud=11.0.2-0)
> [...]
> 07.11.17 14:35:02.232  MODULE      ( PROCESS ) : Copying App Center's store_data to container's /usr/share/univention-docker-container-mode/store_data_custom
> [...]
> 07.11.17 15:00:57.243  MODULE      ( WARN    ) : [('/var/lib/univention-appcenter/apps/nextcloud/data/dummyuser/server_backup.vmdk', 
> '/var/lib/univention-appcenter/backups/appcenter-backup-nextcloud:1510061702/data/dummyuser/server_backup.vmdk', 
> '[Errno 28] Auf dem Ger\xc3\xa4t ist kein Speicherplatz mehr verf\xc3\xbcgbar')


--> No space left on device, /var is 100% full, the upgrade and many other services are stuck
--> The system also needs a re-join because the listener cache (also on /var) was corrupted


System info:
UCS: 4.1-4 errata443
App Center compatibility: 4
Installed: nextcloud=11.0.2-0
Upgradable: nextcloud

> Filesystem                                              Size  Used Avail Use% Mounted on
> udev                                                     10M     0   10M   0% /dev
> tmpfs                                                   799M   13M  787M   2% /run
> /dev/disk/by-uuid/468593cc-c233-4386-890e-65asdf70a176  115G  2.7G  106G   3% /
> tmpfs                                                   5.0M     0  5.0M   0% /run/lock
> tmpfs                                                   2.4G     0  2.4G   0% /run/shm
> /dev/sdc1                                                32G   32G     0 100% /var
> /dev/sdb1                                                32T  109G   31T   1% /var/lib/univention-appcenter/apps/nextcloud/data
> cgroup                                                  4.0G     0  4.0G   0% /sys/fs/cgroup
> overlay                                                  32G   32G     0 100% /var/lib/docker/overlay/7b1dcdb7485928d153125225f18f28d89903490e2aa9320ccc13de865fe1a9d2d/merged
Comment 1 Felix Botner univentionstaff 2018-03-21 18:38:04 CET
We no linger copy the data/conf app directories during app upgrades, so this actual error can no longer happen.

As discussed, additionally we should no longer move the data dir to a backup directory (but for conf dir).

Better do nothing with the apps data.
Comment 2 Felix Botner univentionstaff 2018-04-03 14:13:56 CEST
univention-appcenter
c6690a37479e26a59cb01cf26c6cb08cc986894b

During remove the app's data dir is no longer moved to the backups directory.

https://wiki.univention.de/index.php/Docker_Apps/Image_Based is already updated.

What else?
Comment 3 Dirk Wiesenthal univentionstaff 2018-04-10 12:57:48 CEST
(In reply to Felix Botner from comment #2)
> univention-appcenter
> c6690a37479e26a59cb01cf26c6cb08cc986894b
> 
> During remove the app's data dir is no longer moved to the backups directory.
> 
> https://wiki.univention.de/index.php/Docker_Apps/Image_Based is already
> updated.
> 
> What else?

ucs-test 8.0.28-104A~4.3.0.201804101256

80_docker.58_app_uninstallation.test failed because of that. Which is cool, worked as some kind of negative QA.
Comment 4 Arvid Requate univentionstaff 2018-04-18 13:51:57 CEST
<http://errata.software-univention.de/ucs/4.3/16.html>