Bug 45685 - No Nagios checks for mdb limit / effective size
No Nagios checks for mdb limit / effective size
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: LDAP
UCS 4.2
Other Mac OS X 10.1
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Felix Botner
Arvid Requate
:
: 35422 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-09 22:51 CET by Michel Smidt
Modified: 2018-03-09 12:15 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.046
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2017110221000521
Bug group (optional): Large environments
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Smidt univentionstaff 2017-11-09 22:51:24 CET
To monitor larger environments it is necessary to check for the remaining capacity of the mdb database. The customer had several support cases where especially the database maxsize (ldap/database/mdb/maxsize) and listener cache size (listener/cache/mdb/maxsize) were exceeded.
So, it would be very helpful to get Nagios checks for this mdb limits.
E.g. The customer MDB LDAP limit: 12884901888, effective size: 6442450944, full: 50%
Comment 1 Felix Botner univentionstaff 2017-12-18 15:53:54 CET
univention-nagios
 * added new nagios plugin check_univention_slapd_mdb_maxsize 
   (check_univention_slapd_mdb_maxsize_suidwrapper), checks the total and free
   pages of the mdb ldap database (lmdb-utils) and returns warning if 75%
   or critical if 90% of the total pages are in use
 * 26univention-nagios-common.inst
   add new nagios service UNIVENTION_SLAPD_MDB_MAXSIZE
 * 30univention-nagios-client.inst
   add host to UNIVENTION_SLAPD_MDB_MAXSIZE (only dc)
 * not increased join script version, instead added to yaml how to enable the
   plugin for updates

univention-nagios.yaml

merged to 4.3-0
Comment 2 Arvid Requate univentionstaff 2018-02-13 15:12:33 CET
Ok, check and instructions in Advisory work.
Changes are merged to UCS 4.3 too.
Comment 3 Arvid Requate univentionstaff 2018-02-14 13:31:44 CET
<http://errata.software-univention.de/ucs/4.2/289.html>
Comment 4 Felix Botner univentionstaff 2018-03-09 12:15:19 CET
*** Bug 35422 has been marked as a duplicate of this bug. ***