Bug 45795 - Upgrading a Docker App is not possible if the UCS version changes
Upgrading a Docker App is not possible if the UCS version changes
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-29 13:27 CET by Dirk Wiesenthal
Modified: 2017-12-14 12:55 CET (History)
0 users

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.023
Enterprise Customer affected?:
School Customer affected?:
ISV affected?: Yes
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2017-11-29 13:27:17 CET
Docker Apps with appbox:4.1-4 are installable on UCS 4.2, but technically they belong to UCS 4.1.

UCS 4.2 can download the 4.1-Apps and install the Docker Apps.

If a new version of an App is released that is a Docker App but switched from UCS 4.1 to UCS 4.2, the App Center does not find the new App.
Comment 1 Dirk Wiesenthal univentionstaff 2017-12-05 14:20:37 CET
Fixed in
  univention-appcenter 6.0.11-5A~4.2.0.201712051420

We can now do
  univention-app upgrade openproject
if the installed App version is appbox:4.1-4 and the new version is appbox:4.2-2.
Comment 2 Felix Botner univentionstaff 2017-12-07 13:46:13 CET
OK - update
OK - yaml
Comment 3 Arvid Requate univentionstaff 2017-12-14 12:55:57 CET
<http://errata.software-univention.de/ucs/4.2/250.html>