Bug 45830 - zsyncmake needs an explicit http://
zsyncmake needs an explicit http://
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-07 09:42 CET by Dirk Wiesenthal
Modified: 2018-03-21 13:27 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.023
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2017-12-07 09:42:42 CET
If
  DevRegenerateMetaInf.generate_index_json(meta_inf_dir, repo_dir, ucs_version, appcenter_host)

is called with appcenter_host=somehost.without.scheme, zsyncmake creates an all.tar.zsync that does not work:

bad status code 404
failed to retrieve from appcenter-test.software-univention.de/meta-inf/4.2/all.tar.gz
Aborting, download available in /var/cache/univention-appcenter/appcenter-test.software-univention.de/4.2/.all.tar.part
Downloading the App archive via zsync failed. Falling back to download it directly.
For better performance, try to make zsync work for "http://appcenter-test.software-univention.de/meta-inf/4.2/all.tar.zsync". The error may be caused by a proxy altering HTTP requests

This is a problem in the Provider Portal. We have hotfixed it there, but it is broken in the App Center Dev-Tools.
Comment 1 Stefan Gohmann univentionstaff 2018-03-15 06:38:01 CET
Move to 4.3-0-errata. If a UCS 4.2 backport is needed, please clone this issue.
Comment 2 Dirk Wiesenthal univentionstaff 2018-03-15 14:19:56 CET
Fixed in
  univention-appcenter 7.0.1-29A~4.3.0.201803151413
Comment 3 Felix Botner univentionstaff 2018-03-20 10:25:02 CET
OK - univention-appcenter
OK - YAML
Comment 4 Arvid Requate univentionstaff 2018-03-21 13:27:10 CET
<http://errata.software-univention.de/ucs/4.3/2.html>