Bug 45899 - Request license after successful setup of app appliance raises unknown error
Request license after successful setup of app appliance raises unknown error
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: License
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Erik Damrose
Jürn Brodersen
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-19 16:55 CET by Nico Gulden
Modified: 2018-01-17 14:21 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?: Yes
Waiting Support:
Ticket number: 2017121921000452, 2017120921000042, 2017111021000667
Bug group (optional): Appliance, External feedback
Max CVSS v3 score:


Attachments
Error with BlueSpice Appliance (49.60 KB, image/png)
2018-01-09 17:29 CET, Nico Gulden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2017-12-19 16:55:06 CET
I setup a Kopano app appliance with VirtualBox and went through the system setup wizard. On the screen account information I did _not_ enter an email address to see how the setup handles that. The system setup finished successfully. I then entered the IP address into my browser and was greeted with the form to request a license. I entered my email address and received "Unknown error".

See Ticket#2017121921000452 for a screenshot.

I also tried the other with a new virtual machine and entered the email address on the account information screen. I received an email with the license as expected. This path works.
Comment 1 Nico Gulden univentionstaff 2017-12-21 10:17:15 CET
I have tried the same approach with the Nextcloud App appliance and had the same behavior. When I leave the field for the email address on the screen of the account information during system setup empty, I cannot request a license.
Comment 2 Nico Gulden univentionstaff 2018-01-09 17:29:58 CET
Created attachment 9340 [details]
Error with BlueSpice Appliance

The error occurred again. I used the test build for the BlueSpice appliance for VirtualBox. During the setup I did explicitely not provide and email address. After system setup the browser asked me for the email address as in the attached screenshot.
Comment 3 Nico Gulden univentionstaff 2018-01-11 09:55:56 CET
I just checked the BlueSpice appliance with different browsers.

1) Requesting the license worked with Chromium Version 63.0.3239.84 (Entwickler-Build) built on Debian 9.3, running on Debian 9.3 (64-Bit)

2) The request throwed the error already shown via Screenshot on Firefox ESR 52.5.2 (64-Bit).
Comment 4 Nico Gulden univentionstaff 2018-01-11 11:48:33 CET
I checked again with the Firefox browser and testet another profile without plugins. This profile worked and the license has been requested. Just as side note, I use the HTTPS link, accept the certificate temporarily.
Comment 5 Nico Gulden univentionstaff 2018-01-11 13:14:38 CET
After further investigation it came up that the plugin "Privacy Badge" blocked license.univention.de. The setting for this domain was on "blocked" (left). Changing it to "allowed" (right, green) did trigger a license request.

My Firefox had Privacy Badger 2017.11.20 installed.

Tested with Chromium and blocking license.univention.de triggered the same error.
Comment 6 Stefan Gohmann univentionstaff 2018-01-11 13:37:13 CET
Maybe we could add a knowledge base article which describes the different cases.

We can link the article in the error dialog.
Comment 7 Erik Damrose univentionstaff 2018-01-11 18:00:17 CET
5daffc0 Add information about blocking browser addons to system activation error message

b745d08 + 170360ea fix typo

Package: univention-system-activation
Version: 2.0.2-15A~4.2.0.201801111753
Branch: ucs_4.2-0
Scope: errata4.2-3

univention-system-activation.yaml

3f17043c merge to 4.3, build as univention-system-activation 3.0.0-2A~4.3.0.201801111758

QA: Please test message appearance and QA the support article https://help.univention.com/t/7698
Comment 8 Erik Damrose univentionstaff 2018-01-12 15:14:53 CET
Slight improvement thanks to Florian: The link is now opened in a new tab

6da0b15e + d6495824 4.2-3,
univention-system-activation 2.0.2-16A~4.2.0.201801121501

19b7a584 merge to 4.3
univention-system-activation 3.0.0-3A~4.3.0.201801121514
Comment 9 Jürn Brodersen univentionstaff 2018-01-16 11:34:51 CET
The English message does not end in a dot, the German one does. Is it supposed to be that way?

Should the support article also include a German version?
Comment 10 Erik Damrose univentionstaff 2018-01-16 12:24:04 CET
Current policy is to create english articles only. I would prefer to maintain only one article.

12d6de6f Fix sentence univention-system-activation 2.0.2-17A~4.2.0.201801161217
yaml updated + merged to 4.3
Comment 11 Jürn Brodersen univentionstaff 2018-01-17 10:56:41 CET
Looks good now :)

What I tested:
English/German error message -> OK
Support article -> OK

YAML -> OK

-> Verified
Comment 12 Erik Damrose univentionstaff 2018-01-17 14:21:22 CET
<http://errata.software-univention.de/ucs/4.2/264.html>