Bug 45993 - UCS@school setup fails in 98univention-squid-samba4 with module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
UCS@school setup fails in 98univention-squid-samba4 with module version misma...
Status: RESOLVED DUPLICATE of bug 45326
Product: UCS@school
Classification: Unclassified
Component: Samba
UCS@school 4.2
Other Linux
: P3 normal (vote)
: ---
Assigned To: Samba maintainers
:
Depends on: 40437
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-08 17:05 CET by Daniel Tröder
Modified: 2018-01-09 15:24 CET (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tröder univentionstaff 2018-01-08 17:05:13 CET
+++ This bug was initially created as a clone of Bug #40437 ("UCS@school setup fails as univention-ldb-modules doesn't pull proper libldb1 version") +++

----------------------

Installed the ucsschool app in a UCS 4.3 errata0 and ran the school installer. Everything worked well until it came to the join script 98univention-squid-samba4.inst. It is repeating the last 3 lines in join.log for a while now:

--------------------------------------------------------------------------

RUNNING 98univention-pkgdb-tools.inst
EXITCODE=already_executed
RUNNING 98univention-samba4-dns.inst
2018-01-08 16:47:14.239063737+01:00 (in joinscript_init)
Waiting for RID Pool replication: ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
done.
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
Not updating samba4/sysvol/sync/cron
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
Adding CNAME record "29b63377-d6be-4728-b5c9-258d9678f487._msdcs m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap tcp 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
Does not exist
Adding SRV record "ldap._tcp.dc msdcs 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
Adding SRV record "ldap._tcp.6b3fcea7-3beb-4691-bc48-54a6bd41420a.domains msdcs 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
No record found
Adding SRV record "kerberos tcp 0 100 88 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kerberos udp 0 100 88 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kerberos._tcp.dc msdcs 0 100 88 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kpasswd tcp 0 100 464 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kpasswd udp 0 100 464 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap._tcp.Default-First-Site-Name sites 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap._tcp.Default-First-Site-Name._sites.dc msdcs 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kerberos._tcp.Default-First-Site-Name sites 0 100 88 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "kerberos._tcp.Default-First-Site-Name._sites.dc msdcs 0 100 88 m60.uni.dtr." to zone uni.dtr...
done
Adding TXT record "_kerberos UNI.DTR" to zone uni.dtr...
done
Adding A record "gc._msdcs 10.200.3.60" to zone uni.dtr...
done
Adding SRV record "gc tcp 0 100 3268 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap._tcp.gc msdcs 0 100 3268 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "gc._tcp.Default-First-Site-Name sites 0 100 3268 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap._tcp.Default-First-Site-Name._sites.gc msdcs 0 100 3268 m60.uni.dtr." to zone uni.dtr...
done
Adding SRV record "ldap._tcp.pdc msdcs 0 100 389 m60.uni.dtr." to zone uni.dtr...
done
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
2018-01-08 16:47:33.522328507+01:00 (in joinscript_save_current_version)
EXITCODE=0
RUNNING 98univention-samba4slavepdc-dns.inst
2018-01-08 16:47:33.551080994+01:00 (in joinscript_init)
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
2018-01-08 16:47:34.732104107+01:00 (in joinscript_save_current_version)
EXITCODE=0
RUNNING 98univention-squid-samba4.inst
2018-01-08 16:47:35.104856521+01:00 (in joinscript_init)
Object created: uid=http-proxy-m60,cn=users,dc=uni,dc=dtr
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
Comment 1 Daniel Tröder univentionstaff 2018-01-08 17:09:04 CET
[..]
looking for spn account "http-proxy-m60" in local samba
ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.2.3 module_version=1.2.2
ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.2.3 module_version=1.2.2
ERROR: samAccountName not found for service account http-proxy-m60
ERROR: cannot add attribute "servicePrincipalName: HTTP/m60.uni.dtr"
EXITCODE=1
RUNNING 99ucs-school-netlogon-user-logonscripts.inst
EXITCODE=already_executed
RUNNING 99ucs-school-netlogon.inst
EXITCODE=already_executed
RUNNING 99ucs-school-umc-printermoderation.inst
EXITCODE=already_executed
RUNNING 99ucsschool-italc-key.inst
EXITCODE=already_executed

Mo 8. Jan 17:08:01 CET 2018
univention-run-join-scripts finished
Comment 2 Arvid Requate univentionstaff 2018-01-09 15:24:19 CET
Fixed by b43 univention-ldb-modules

*** This bug has been marked as a duplicate of bug 45326 ***