Bug 46006 - univention-samba4 join of non-school Slave fails in UCS@school
univention-samba4 join of non-school Slave fails in UCS@school
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Felix Botner
Arvid Requate
:
Depends on:
Blocks: 43155
  Show dependency treegraph
 
Reported: 2018-01-10 17:02 CET by Arvid Requate
Modified: 2018-03-28 13:28 CEST (History)
10 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2018010421000767
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2018-01-10 17:02:28 CET
The join of a non-school UCS Slave with univention-samba4 into an the UCS@school domain (central department) fails because the 96univention-samba4.inst joinscript fails with this message:

File: /etc/samba/base.conf
Multifile: /etc/samba/smb.conf
ERROR: We are joining to an UCS@school domain but shell-ucs-school is not installed
ERROR: Make sure that UCS@school metapackages are installed properly
Comment 1 Valentin Heidelberger univentionstaff 2018-02-04 17:56:30 CET
Reproduced this on a UCS backup with UCS@school installed.

- Install UCS@school on master and backup
- Install Samba on backup
- Join scripts fail
Comment 2 Arvid Requate univentionstaff 2018-02-05 13:01:58 CET
Comment 1 doesn't refer to the topic of this bug, as it says:

> - Install UCS@school on master and backup
Comment 3 Felix Botner univentionstaff 2018-03-19 17:18:48 CET
univention-samba4 727c550d82e50deefbbc619a74bbf0fd8f408565
copied school lib functions to s4 libs.

yaml: 3b457787872aa742816d09298d45ca1e23279b92
Comment 4 Arvid Requate univentionstaff 2018-03-27 18:21:07 CEST
Ok, works now and advisory is ok too.
Comment 5 Arvid Requate univentionstaff 2018-03-28 13:28:32 CEST
<http://errata.software-univention.de/ucs/4.3/5.html>