Bug 46323 - Configuring Active Directory connection: ValueError: need more than 1 value to unpack
Configuring Active Directory connection: ValueError: need more than 1 value t...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: AD Connector
UCS 4.4
Other Linux
: P5 normal (vote)
: UCS 4.4-0-errata
Assigned To: Fathan Vidjaja
Arvid Requate
:
: 49229 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-16 17:50 CET by Johannes Keiser
Modified: 2019-07-03 14:13 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2018041321001011, 2018020521001021, 2019040421000456
Bug group (optional): External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (git:fbest/46323-fix-ad-ldap-escaping) (12.56 KB, patch)
2019-05-13 13:59 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Keiser univentionstaff 2018-02-16 17:50:43 CET
Version: 4.2-3 errata284 (Lesum)

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/modules/setup/setup_script.py", line 310, in run
    success = self.inner_run()
  File "/usr/lib/univention-system-setup/scripts/90_postjoin/10admember", line 126, in inner_run
    admember.synchronize_account_position(ad_domain_info, username, password)
  File "%PY2.7%/univention/lib/admember.py", line 563, in synchronize_account_position
    mapped_ad_user_dn = _mapped_ad_dn(ad_user_dn, ad_ldap_base, ucr)
  File "%PY2.7%/univention/lib/admember.py", line 504, in _mapped_ad_dn
    attr, val = rdn.split('=')
ValueError: need more than 1 value to unpack
Comment 1 Johannes Keiser univentionstaff 2018-04-13 11:27:11 CEST
Reported again: Version: 4.3-0 errata12 (Neustadt)
Comment 2 Florian Best univentionstaff 2019-04-04 16:45:16 CEST
*** Bug 49229 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2019-04-04 16:45:54 CEST
Einrichten der Active-Directory-Verbindung: Traceback (most recent call last):
Einrichten der Active-Directory-Verbindung: File "%PY2.7%/univention/management/console/modules/setup/setup_script.py", line 310, in run
Einrichten der Active-Directory-Verbindung: success = self.inner_run()
Einrichten der Active-Directory-Verbindung: File "/usr/lib/univention-system-setup/scripts/90_postjoin/10admember", line 126, in inner_run
Einrichten der Active-Directory-Verbindung: admember.synchronize_account_position(ad_domain_info, username, password)
Einrichten der Active-Directory-Verbindung: File "%PY2.7%/univention/lib/admember.py", line 609, in synchronize_account_position
Einrichten der Active-Directory-Verbindung: mapped_ad_user_dn = _mapped_ad_dn(ad_user_dn, ad_ldap_base, ucr)
Einrichten der Active-Directory-Verbindung: File "%PY2.7%/univention/lib/admember.py", line 550, in _mapped_ad_dn
Einrichten der Active-Directory-Verbindung: attr, val = rdn.split('=')
Einrichten der Active-Directory-Verbindung: ValueError: need more than 1 value to unpack
Comment 4 Ingo Steuwer univentionstaff 2019-05-13 11:40:38 CEST
Do we know the use case that triggers this traceback?
Comment 5 Florian Best univentionstaff 2019-05-13 12:57:30 CEST
(In reply to Ingo Steuwer from comment #4)
> Do we know the use case that triggers this traceback?
It happens if you have any container or user containing a "," in the AD LDAP.
Comment 6 Florian Best univentionstaff 2019-05-13 13:59:56 CEST
Created attachment 10023 [details]
patch (git:fbest/46323-fix-ad-ldap-escaping)
Comment 7 Fathan Vidjaja univentionstaff 2019-06-27 12:31:06 CEST
Patch is merged and built in univention-lib ver. 8.0.1-24A~4.4.0.201906271220.

6e526cdb :Bug #46323: fix escaping of ldap DN and filters, and shell arguments
281e3705 :Bug #46323: Version Bump
bfd4da81 :Bug #4323: yaml
Comment 8 Arvid Requate univentionstaff 2019-07-03 13:24:29 CEST
Verified:
* Code ereview
* Package update
* Jenkins Tests
* Advisory
Comment 9 Arvid Requate univentionstaff 2019-07-03 14:13:33 CEST
<http://errata.software-univention.de/ucs/4.4/173.html>