Bug 46585 - Converting packages from "unmaintained" to "maintained" required by UCS@school
Converting packages from "unmaintained" to "maintained" required by UCS@school
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-1
Assigned To: Philipp Hahn
Erik Damrose
:
: 46833 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-11 23:29 CET by Sönke Schwardt-Krummrich
Modified: 2018-06-12 13:12 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Release Management
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2018-03-11 23:29:22 CET
The following packages should be converted in UCS 4.3 from "unmaintained" to "maintained" since they are required by UCS@school:
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2018-03-12 00:03:23 CET
The following *binary* packages should be converted in UCS 4.3 from "unmaintained" to "maintained" since they are required by UCS@school:

gunicorn
python-backports-abc
python-django
python-django-celery
python-django-common
python-djangorestframework
python-djangorestframework-doc
python-gunicorn
python-pampy
Comment 2 Sönke Schwardt-Krummrich univentionstaff 2018-06-04 12:46:38 CEST
*** Bug 46833 has been marked as a duplicate of this bug. ***
Comment 3 Philipp Hahn univentionstaff 2018-06-05 15:56:11 CEST
r83016 | Bug #46585: Add maintained UCS@school packages
Comment 4 Erik Damrose univentionstaff 2018-06-11 14:20:11 CEST
OK python-django
OK python-django-common

Reopen: still unmaintained:
python-django-celery
gunicorn
python-backports-abc
python-djangorestframework
python-djangorestframework-doc
python-gunicorn
python-pampy
Comment 5 Philipp Hahn univentionstaff 2018-06-11 15:41:01 CEST
(In reply to Erik Damrose from comment #4)
> OK python-django
> OK python-django-common
> 
> Reopen: still unmaintained:
> python-django-celery

repo-copy-dsc -vvvv ../ucs_4.3-0/source/django-celery_3.1.17-4.dsc

> gunicorn
> python-gunicorn

repo-copy-dsc -vvvv ../ucs_4.3-0/source/gunicorn_19.6.0-10+deb9u1.dsc

> python-backports-abc

repo-copy-dsc -vvvv ../ucs_4.3-0/source/python-backports-abc_0.5-1.dsc

> python-djangorestframework
> python-djangorestframework-doc

repo-copy-dsc -vvvv ../ucs_4.3-0/source/djangorestframework_3.4.0-2.dsc
repo-copy-dsc -vvvv ../ucs_4.3-0/source/python-markdown_2.6.8-1.dsc

> python-pampy

repo-copy-dsc -vvvv ../ucs_4.3-0/source/python-pampy_1.8.2-1+deb9u1.dsc

repo-apt-ftparchive --release ucs_4.3-0-ucs4.3-1

<http://jenkins.knut.univention.de:8080/job/Mitarbeiter/job/phahn/job/CalculateMaintained/82/console>

QA:
cat >/etc/apt/sources.list./ucs431.list <<__APT__
deb [trusted=yes] http://omar.knut.univention.de/build2 ucs_4.3-0-ucs4.3-1/\$(ARCH)/
deb [trusted=yes] http://omar.knut.univention.de/build2 ucs_4.3-0-ucs4.3-1/all/
__APT__
apt-get -qq update
xargs -n1 apt-get -qq -d --print-uris install <<__PKG__
gunicorn
python-backports-abc
python-django
python-django-celery
python-django-common
python-djangorestframework
python-djangorestframework-doc
python-gunicorn
python-pampy
__PKG__

<http://jenkins.knut.univention.de:8080/view/Publish/job/Publish%20UCS%204%20to%20testing/1953/console>

QA:
cat >/etc/apt/sources.list./ucs431.list <<__APT__
deb [trusted=yes] http://apt.knut.univention.de/4.3/maintained/ 4.3-1/\$(ARCH)/
deb [trusted=yes] http://apt.knut.univention.de/4.3/maintained/ 4.3-1/all/
__APT__
...
Comment 6 Erik Damrose univentionstaff 2018-06-11 17:07:50 CEST
Verified: All packages are maintained in UCS 4.3-1
~Changelog added in 65432b6a
Comment 7 Erik Damrose univentionstaff 2018-06-12 13:12:00 CEST
UCS 4.3-1 has been released.