Bug 46607 - dhcp failover is broken - mismerged patch?
dhcp failover is broken - mismerged patch?
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: DHCP
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Philipp Hahn
Jürn Brodersen
https://hutten.knut.univention.de/med...
:
: 46697 (view as bug list)
Depends on:
Blocks: 46404
  Show dependency treegraph
 
Reported: 2018-03-12 16:27 CET by Philipp Hahn
Modified: 2018-03-21 13:27 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.046
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-03-12 16:27:26 CET
dhcpd failover no longer can be configured - see URL for my HOWTO

# dhcpd -f -d
failover peer foobar: I move from recover to startup
failover peer declaration with no referring pools.
In order to use failover, you MUST refer to your main failover declaration
in each pool declaration.   You MUST NOT use range declarations outside
of pool declarations.

# less /var/log/dhcp-ldap-startup.log
#DHCP Service
 filename "pxelinux.0";
next-server 192.168.10.13;
subnet 192.168.10.0 netmask 255.255.255.0 {
 filename "pxelinux.0";
 next-server 192.168.10.13;
 pool {
  range 192.168.10.2 192.168.10.127;
  deny dynamic bootp clients;
  filename "pxelinux.0";
  next-server 192.168.10.13;
 }
}

# svn log 28_ldap_oc.quilt
r17769 | arequate | 2017-11-23 19:10:32 +0100 (Do, 23. Nov 2017) | 2 Zeilen
r17767 | arequate | 2017-11-23 18:58:43 +0100 (Do, 23. Nov 2017) | 2 Zeilen
r17765 | arequate | 2017-11-23 18:21:22 +0100 (Do, 23. Nov 2017) | 2 Zeilen
r17763 | arequate | 2017-11-23 16:16:53 +0100 (Do, 23. Nov 2017) | 2 Zeilen
Comment 1 Philipp Hahn univentionstaff 2018-03-13 13:59:35 CET
Yes, the patch was mismerged into ldap_parse_failover() instead of ldap_parse_failover().

r18052 | Bug #46607: isc-dhcp failover

Package: isc-dhcp
Version: 4.3.5-3+deb9u1A~4.3.0.201803131309
Branch: ucs_4.3-0
Scope: errata4.3-0

[4.3-0] 7c4f04d6eb Bug #46607: isc-dhcp
 doc/errata/staging/isc-dhcp.yaml | 10 ++++++++++

QA: See <https://hutten.knut.univention.de/mediawiki/index.php/Philipp_memo/DHCP#Failover>
Comment 2 Constin 2018-03-19 15:16:17 CET
your link is broken
Comment 3 Philipp Hahn univentionstaff 2018-03-19 15:47:14 CET
*** Bug 46697 has been marked as a duplicate of this bug. ***
Comment 4 Constin 2018-03-19 15:50:23 CET
If it's known bug and WILL BE fixed, why this case has status "RESOLVED FIXED"?
where is fix?
Comment 5 Constin 2018-03-19 15:51:58 CET
nslookup hutten.knut.univention.de 8.8.8.8
Server:		8.8.8.8
Address:	8.8.8.8#53

** server can't find hutten.knut.univention.de: NXDOMAIN
Comment 6 Philipp Hahn univentionstaff 2018-03-19 15:53:05 CET
(In reply to Constin from comment #4)
> If it's known bug and WILL BE fixed, why this case has status "RESOLVED
> FIXED"?
> where is fix?

Waiting for QA to finish its job. After that the fixed package will be released to public, which is "VERIFIED" and than "CLOSED".
Comment 7 Philipp Hahn univentionstaff 2018-03-19 15:53:54 CET
(In reply to Constin from comment #2)
> your link is broken

(In reply to Constin from comment #5)
> nslookup hutten.knut.univention.de 8.8.8.8
...
> ** server can't find hutten.knut.univention.de: NXDOMAIN

You are not allowed to access our internal systems; so please wait.
Comment 8 Jürn Brodersen univentionstaff 2018-03-19 17:40:56 CET
OK
What I tested:
Setup two dhcp server with failover configured -> DHCP works -> OK
leases are synced -> OK (/var/lib/dhcp/dhcpd.leases)
'failover peer "foobar" state' -> OK (/var/lib/dhcp/dhcpd.leases)
Stopping one dhcp server -> DHCP still works -> OK
YAML -> OK

Verified -> OK
Comment 9 Arvid Requate univentionstaff 2018-03-21 13:27:28 CET
<http://errata.software-univention.de/ucs/4.3/1.html>