Bug 46686 - firefox-esr: Multiple issues (4.3)
firefox-esr: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P3 normal (vote)
: UCS 4.3-0-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-16 17:24 CET by Philipp Hahn
Modified: 2018-05-16 17:04 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 8.8 (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-03-16 17:24:50 CET
New Debian firefox-esr 52.7.1esr-1~deb9u1 fixes:
This update addresses the following issues:
* CVE-2018-5125: Memory safety bugs fixed in Firefox 59 and Firefox ESR 52.7
  (MFSA 2018-07)
* CVE-2018-5127: Buffer overflow manipulating SVG animatedPathSegList (MFSA
  2018-07)
* CVE-2018-5129: Out-of-bounds write with malformed IPC messages (MFSA
  2018-07)
* CVE-2018-5130: Mismatched RTP payload type can trigger memory corruption
  (MFSA 2018-07)
* CVE-2018-5131: Fetch API improperly returns cached copies of
  no-store/no-cache resources (MFSA 2018-07)
* CVE-2018-5144: Integer overflow during Unicode conversion (MFSA 2018-07)
* CVE-2018-5145: Memory safety bugs fixed in Firefox ESR 52.7 (MFSA 2018-07)

CVE-2018-5127 Mozilla: Buffer overflow manipulating SVG animatedPathSegList (MFSA 2018-07)
CVE-2018-5129 Mozilla: Out-of-bounds write with malformed IPC messages (MFSA 2018-07)
CVE-2018-5130 Mozilla: Mismatched RTP payload type can trigger memory corruption (MFSA 2018-07)
CVE-2018-5131 Mozilla: Fetch API improperly returns cached copies of no-store/no-cache resources (MFSA 2018-07)
CVE-2018-5144 Mozilla: Integer overflow during Unicode conversion (MFSA 2018-07)
CVE-2018-5125 Mozilla: Memory safety bugs fixed in Firefox 59 and Firefox ESR 52.7 (MFSA 2018-07)
CVE-2018-5145 Mozilla: Memory safety bugs fixed in Firefox ESR 52.7 (MFSA 2018-07)
Comment 1 Philipp Hahn univentionstaff 2018-03-16 17:25:57 CET
[4.3-0] 95091680c5 Bug #46686: firefox-esr_52.7.1esr-1~deb9u1

Copied from Debian-Stretch
Comment 2 Philipp Hahn univentionstaff 2018-03-19 13:37:04 CET
[4.3-0] f8ba8499d4 Bug #46686: firefox-esr_52.7.2esr-1~deb9u1
 doc/errata/staging/firefox-esr.yaml | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

Copied from Debian
Comment 3 Philipp Hahn univentionstaff 2018-04-04 17:20:23 CEST
[4.3-0] a90608b030 Bug #46686: firefox-esr 52.7.3esr-1~deb9u1
Comment 4 Quality Assurance univentionstaff 2018-05-04 16:43:44 CEST
--- mirror/ftp/4.2/unmaintained/component/4.2-3-errata/source/firefox-esr_52.7.3esr-1~deb8u1.dsc
+++ apt/ucs_4.3-0-errata4.3-0/source/firefox-esr_52.7.3esr-1~deb9u1.dsc
@@ -1,14 +1,14 @@
-52.7.3esr-1~deb8u1 [Tue, 27 Mar 2018 08:03:45 +0900] Mike Hommey <glandium@debian.org>:
+52.7.3esr-1~deb9u1 [Tue, 27 Mar 2018 08:03:45 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-10, also known as CVE-2018-5148.
 
-52.7.2esr-1~deb8u1 [Sat, 17 Mar 2018 07:26:52 +0900] Mike Hommey <glandium@debian.org>:
+52.7.2esr-1~deb9u1 [Sat, 17 Mar 2018 07:26:52 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-08, also known as CVE-2018-5146, CVE-2018-5147.
 
-52.7.1esr-1~deb8u1 [Thu, 15 Mar 2018 08:29:27 +0900] Mike Hommey <glandium@debian.org>:
+52.7.1esr-1~deb9u1 [Thu, 15 Mar 2018 08:29:27 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-07, also known as
@@ -19,7 +19,7 @@
     http://bugs.icu-project.org/trac/changeset/40603 to fix FTBFS with glibc
     2.26 on big endian platforms.
 
-52.6.0esr-1~deb8u1 [Wed, 24 Jan 2018 06:51:46 +0900] Mike Hommey <glandium@debian.org>:
+52.6.0esr-1~deb9u1 [Wed, 24 Jan 2018 06:51:46 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-03, also known as
@@ -27,12 +27,12 @@
     CVE-2018-5098, CVE-2018-5099, CVE-2018-5102, CVE-2018-5103,
     CVE-2018-5104, CVE-2018-5117, CVE-2018-5089.
 
-52.5.2esr-1~deb8u1 [Fri, 08 Dec 2017 20:41:27 +0900] Mike Hommey <glandium@debian.org>:
+52.5.2esr-1~deb9u1 [Fri, 08 Dec 2017 20:41:27 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-28, also known as CVE-2017-7843.
 
-52.5.0esr-1~deb8u1 [Wed, 15 Nov 2017 07:19:57 +0900] Mike Hommey <glandium@debian.org>:
+52.5.0esr-1~deb9u1 [Wed, 15 Nov 2017 07:19:57 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-25, also known as:
@@ -41,7 +41,7 @@
   * debian/source/lintian-overrides: Add a lintian override for dotzlib.chm.
   * debian/import-tar.py: Make python 3.6 happy.
 
-52.4.0esr-1~deb8u1 [Fri, 29 Sep 2017 06:02:52 +0900] Mike Hommey <glandium@debian.org>:
+52.4.0esr-1~deb9u1 [Fri, 29 Sep 2017 06:02:52 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-22, also known as:
@@ -49,14 +49,12 @@
     CVE-2017-7805, CVE-2017-7814, CVE-2017-7823, CVE-2017-7810.
   * debian/rules: Really build with gcc 6 on unstable. Closes: #871583.
 
-52.3.0esr-1~deb8u2 [Fri, 11 Aug 2017 18:19:19 +0900] Mike Hommey <glandium@debian.org>:
-
   * js/src/jsmath.cpp: Add GETRANDOM_NR definition for powerpc and mips.
     bz#1389281.
   * media/libcubeb/tests/moz.build: Fixup workaround for binutil assertion on
     mips.
 
-52.3.0esr-1~deb8u1 [Wed, 09 Aug 2017 06:52:55 +0900] Mike Hommey <glandium@debian.org>:
+52.3.0esr-1~deb9u1 [Wed, 09 Aug 2017 06:52:55 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-19, also known as:
@@ -81,7 +79,7 @@
     - media/libyuv/source/row_mips.cc: Only use the perf opcode on mips arches
       that support it. bz#1012232.
 
-52.2.0esr-1~deb8u1 [Wed, 14 Jun 2017 07:53:34 +0900] Mike Hommey <glandium@debian.org>:
+52.2.0esr-1~deb9u1 [Wed, 14 Jun 2017 07:53:34 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-16, also known as:
Comment 5 Philipp Hahn univentionstaff 2018-05-11 15:47:24 CEST
[4.3-0] 12f7dd0cbd Bug #46686: firefox-esr 52.8.0esr-1~deb9u1
 doc/errata/staging/firefox-esr.yaml | 21 ++++++++++++++++++++-
Comment 6 Quality Assurance univentionstaff 2018-05-11 15:50:05 CEST
--- mirror/ftp/4.2/unmaintained/component/4.2-3-errata/source/firefox-esr_52.7.3esr-1~deb8u1.dsc
+++ apt/ucs_4.3-0-errata4.3-0/source/firefox-esr_52.8.0esr-1~deb9u1.dsc
@@ -1,14 +1,22 @@
-52.7.3esr-1~deb8u1 [Tue, 27 Mar 2018 08:03:45 +0900] Mike Hommey <glandium@debian.org>:
+52.8.0esr-1~deb9u1 [Thu, 10 May 2018 08:30:12 +0900] Mike Hommey <glandium@debian.org>:
+
+  * New upstream release.
+  * Fixes for mfsa2018-12, also known as
+    CVE-2018-5183, CVE-2018-5154, CVE-2018-5155, CVE-2018-5157,
+    CVE-2018-5158, CVE-2018-5159, CVE-2018-5168, CVE-2018-5178,
+    CVE-2018-5150.
+
+52.7.3esr-1~deb9u1 [Tue, 27 Mar 2018 08:03:45 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-10, also known as CVE-2018-5148.
 
-52.7.2esr-1~deb8u1 [Sat, 17 Mar 2018 07:26:52 +0900] Mike Hommey <glandium@debian.org>:
+52.7.2esr-1~deb9u1 [Sat, 17 Mar 2018 07:26:52 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-08, also known as CVE-2018-5146, CVE-2018-5147.
 
-52.7.1esr-1~deb8u1 [Thu, 15 Mar 2018 08:29:27 +0900] Mike Hommey <glandium@debian.org>:
+52.7.1esr-1~deb9u1 [Thu, 15 Mar 2018 08:29:27 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-07, also known as
@@ -19,7 +27,7 @@
     http://bugs.icu-project.org/trac/changeset/40603 to fix FTBFS with glibc
     2.26 on big endian platforms.
 
-52.6.0esr-1~deb8u1 [Wed, 24 Jan 2018 06:51:46 +0900] Mike Hommey <glandium@debian.org>:
+52.6.0esr-1~deb9u1 [Wed, 24 Jan 2018 06:51:46 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2018-03, also known as
@@ -27,12 +35,12 @@
     CVE-2018-5098, CVE-2018-5099, CVE-2018-5102, CVE-2018-5103,
     CVE-2018-5104, CVE-2018-5117, CVE-2018-5089.
 
-52.5.2esr-1~deb8u1 [Fri, 08 Dec 2017 20:41:27 +0900] Mike Hommey <glandium@debian.org>:
+52.5.2esr-1~deb9u1 [Fri, 08 Dec 2017 20:41:27 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-28, also known as CVE-2017-7843.
 
-52.5.0esr-1~deb8u1 [Wed, 15 Nov 2017 07:19:57 +0900] Mike Hommey <glandium@debian.org>:
+52.5.0esr-1~deb9u1 [Wed, 15 Nov 2017 07:19:57 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-25, also known as:
@@ -41,7 +49,7 @@
   * debian/source/lintian-overrides: Add a lintian override for dotzlib.chm.
   * debian/import-tar.py: Make python 3.6 happy.
 
-52.4.0esr-1~deb8u1 [Fri, 29 Sep 2017 06:02:52 +0900] Mike Hommey <glandium@debian.org>:
+52.4.0esr-1~deb9u1 [Fri, 29 Sep 2017 06:02:52 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-22, also known as:
@@ -49,14 +57,12 @@
     CVE-2017-7805, CVE-2017-7814, CVE-2017-7823, CVE-2017-7810.
   * debian/rules: Really build with gcc 6 on unstable. Closes: #871583.
 
-52.3.0esr-1~deb8u2 [Fri, 11 Aug 2017 18:19:19 +0900] Mike Hommey <glandium@debian.org>:
-
   * js/src/jsmath.cpp: Add GETRANDOM_NR definition for powerpc and mips.
     bz#1389281.
   * media/libcubeb/tests/moz.build: Fixup workaround for binutil assertion on
     mips.
 
-52.3.0esr-1~deb8u1 [Wed, 09 Aug 2017 06:52:55 +0900] Mike Hommey <glandium@debian.org>:
+52.3.0esr-1~deb9u1 [Wed, 09 Aug 2017 06:52:55 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-19, also known as:
@@ -81,7 +87,7 @@
     - media/libyuv/source/row_mips.cc: Only use the perf opcode on mips arches
       that support it. bz#1012232.
 
-52.2.0esr-1~deb8u1 [Wed, 14 Jun 2017 07:53:34 +0900] Mike Hommey <glandium@debian.org>:
+52.2.0esr-1~deb9u1 [Wed, 14 Jun 2017 07:53:34 +0900] Mike Hommey <glandium@debian.org>:
 
   * New upstream release.
   * Fixes for mfsa2017-16, also known as:
Comment 7 Arvid Requate univentionstaff 2018-05-14 19:17:02 CEST
* No UCS specific patches
* Comparison to previously shipped version ok
* Binary package update Ok
* Advisory adjusted:
  29f9b44692 | Sort CVEs
Comment 8 Arvid Requate univentionstaff 2018-05-16 17:04:14 CEST
<http://errata.software-univention.de/ucs/4.3/51.html>