Bug 46698 - Nagios CUPS test fails due to usage of HTTP 1.0
Nagios CUPS test fails due to usage of HTTP 1.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Nagios - plugins
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-1-errata
Assigned To: Jürn Brodersen
Felix Botner
:
: 46701 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-19 16:31 CET by Moritz Bunkus
Modified: 2018-08-15 13:14 CEST (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support: Yes
Ticket number: 2018070621000654, 2018071321000195
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Bunkus 2018-03-19 16:31:40 CET
In UCS 4.3 the CUPS NRPE check runs the following:

/usr/lib/nagios/plugins/check_http -I 127.0.0.1 -p 631 -S -k "Host: 127.0.0.1:631"

This fails with an error message (even though the web interface is apparently working just fine when you visit it with a browser):

[0 root@master /etc/nagios/nrpe.univention.d] /usr/lib/nagios/plugins/check_http -I 127.0.0.1 -p 631 -S -k "Host: 127.0.0.1:631"
HTTP WARNING: HTTP/1.0 400 Bad Request - 648 bytes in 0,009 second response time |time=0,008514s;;;0,000000;10,000000 size=648B;;;0

The reason seems to be that CUPS doesn't support HTTP 1.0 anymore. Forcing the check to use 1.1 by adding `-S 1.1` results in a positive check:

[0 root@master /etc/nagios/nrpe.univention.d] /usr/lib/nagios/plugins/check_http -I 127.0.0.1 -p 631 -S -k "Host: 127.0.0.1:631" -S 1.1
HTTP OK: HTTP/1.1 200 OK - 2754 bytes in 0,008 second response time |time=0,007632s;;;0,000000;10,000000 size=2754B;;;0

How to reproduce:

• Install the CUPS & Nagios apps on UCS 4.3
• Configure the server for Nagios, add the CUPS check
• Observe the result

Other users have reported the same issue:

https://help.univention.com/t/nagios-problem-after-update-ucs-v4-3-http-warning/8201
Comment 1 Erik Damrose univentionstaff 2018-03-20 08:57:40 CET
*** Bug 46701 has been marked as a duplicate of this bug. ***
Comment 2 Timo Denissen univentionstaff 2018-05-14 08:33:13 CEST
We now have three internal systems with this error.
Comment 3 Christina Scheinig univentionstaff 2018-07-09 09:39:30 CEST
A school customer now stumbles over this issue
Comment 4 Christina Scheinig univentionstaff 2018-07-13 09:33:39 CEST
Again in the next school environment.
I set both tickets waiting for this bugfix
Comment 5 Jürn Brodersen univentionstaff 2018-08-08 14:31:46 CEST
[4.3-1 5af158873c] Bug #46698: Use the host header option to ensure HTTP/1.1 is used
[4.3-1 75cc0e523e] Bug #46698: YAML

Package: univention-nagios-servicechecks
Version: 7.0.0-3A~4.3.0.201808081424
Branch: ucs_4.3-0
Scope: errata4.3-1
Comment 6 Felix Botner univentionstaff 2018-08-14 10:00:33 CEST
OK - univention-nagios-cups
OK - yaml
Comment 7 Arvid Requate univentionstaff 2018-08-15 13:14:29 CEST
<http://errata.software-univention.de/ucs/4.3/169.html>